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Chapter 1 Introduction to GstarCAD 

1.1. Introduction to GstarCAD 

1.1.1. System requirement 

You need the following software and hardware to install and run GstarCAD:   

 Microsoft Windows 2000, 2003, XP, Vista, Windows 7 (Windows2000, XP    

recommended); 

 Intel Pentium(or faster) Processor ;                                                      

 Minimum 512M RAM (above 1G RAM recommended) ; 

 More than 300 MB Hard Disk(above 1G recommended); 

 CD-ROM drive needed if installing from a CD; 

 Mouse or other coordinates input devices; 

 Color Monitor; 

 Output Devices (Printer or Plotter). 

 

1.1.2.  Installation and Registry 

 The installation of GstarCAD 

The GstarCAD installation program will lead you to finish the installation, the 

installation program will automatically create a folder which contains all programs, at 

the same time a program startup bar will be created at the “Start” menu of Windows, a 

shortcut icon will be created at desktop. 

Users can use CD or copy installation program to your personal PC or the hard disc 

of server to install. 

Install steps: 

1.Enter the GstarCAD installation content, double-click the execute file, the 

installation setup interface is displayed and prompt that user system is preparing 

“Installation wizard” and do some preparation for installation.  

 



 

 
 
 

GstarCAD 2010 –Fluent Use in Entire Design 
 

www.staricad.com              2         support @staricad.com 
 
 
 
 
 
 

 

2. After “Installation wizard” finishes installing, Installation wizard dialog is 

displayed. Click “next” button to continue installing. 

 
 
 

3. “License Agreement” dialog box is displayed, as the below picture, if you agree 

with the agreement, click “I Agree” to continue 

 
 
 

4. The user information dialog box is displayed, after you inputting user 

information, click “Next” button                                   
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5. “Installation type” dialog box is displayed, as the below. 

If you buy Stand-alone version or try software, you can use the default stand-alone to 

install; if you buy the network version, please select “Network” to install. 

 
 
 

6. After you select the right installation type, click “Next” button, “Choose 

Destination Location” dialog box is displayed, as the below. 

Click “Browse” button to select anther folder. 
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7. Click “Next” button, “Start Copying Files” dialog box is displayed, user can 

check or modify the inputted information through this dialog box. If there are some 

information to modify, click “Back” button to return to the last dialog box to modify;  

If there are no information to modify, click “Next” button and the system begin to install 

the software. 
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Click “Finish” to complete the software installation 

 

 The registry of GstarCAD 

Click the icon on the desktop to start up GstarCAD. If you don’t register software, 

at the title bar there is tryout software prompt  

There are two authorization methods: Dongle and Registration Number 

1、Dongle 

Dongle is divided into stand-alone version and network version.  

A stand-alone version belongs to a single customer, you needn’t install driver, 

software will finish the register automatically. 

Network version should be set up on the server (any computer in network), but the 

number of users should limit within the authorized number by the network lock. 

If you install network version please select any a computer as the server, and install 

network lock driver at this server computer (the network lock driver is in the Driver 

content). When you install GstarCAD at customer end, please select “Network”, once 

you start CAD, and the software will automatically search for network lock to finish 

registering. If the software is still in the tryout situation, please input the server name or 

IP address at the program item of GstarCAD. If there still doesn’t work well please 

check firewall settings or contact with us. 

If you want to use network lock at different net, you should set a system variable at your 

customer end, the steps is below: 

Start>Control panel>System>Advanced>Environment Variables>New a environment 

variable, the variable name is "NSP_HOST"，the variable value is the IP address of the 
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Server 

2、Registration Number 

The operation step about registration number is below: 

1). Install the stand-alone GstarCAD 

2) Click Help>Register, GstarCAD will generate a serial number, this serial 

number is corresponding to your computer 

 
 
 

3) You should send the serial number to our company, we will calculate a 

activation number to you according your serial number. 

Note: The tryout limit is 30 days, there is no function limitation in the tryout days, 

but you had better complete the registration before tryout expiration. 

4). Open “Activation” dialog box, input the activation number, then click Activate 

button to finish register 

5). Restart GstarCAD, and check whether the software has been activated. 

1.1.3. Learn About New Features in GstarCAD2010 

The New Features Workshop introduces you to what's new in GstarCAD2010. 

1. Compatible with AutoCAD 2010 DWG file 

 Support AutoCAD R2.5~2010 

GstarCAD 2010 uses the latest ODA library and can open AutoCAD R2.5~2010 

DWGfile. 
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 Fully Compatible with Windows 7 

 Freely and easily port into GstarCAD with “0”Cost 
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2. Great Features - Productivity Features for Improving Drawing Efficiency 

 

             
 MTEXT- Freely and quickly edit the text 

Adopts the brand-new In-Place MTEXT Editor which makes your work experience 

more efficient with new and improved functions such as a new text formatting toolbar, a 

new dialog box for formatting paragraphs, and a new display options menu. So you can 

create and edit text objects freely! 
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 Associative  Dimension:  Adjust  Dimension  Automatically  to  improve  

Drawing Efficiency 

Realizes the Associative Dimension in Model Space. If the associative point on the 

objects changes the dimension place or orientation, the value will update automatically. 
 

 
 
● Powerful Table Tool :AutoXLSTable----feel exchanges ideals between CAD and 

Excel (Only GstarCAD Premium version have this function) 
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AutoXlsTable can account block quantities, objects area and length. The data in the table 

will be updated automatically according to the modification of objects. 

If the original Excel table “Excel spreadsheet1” quotes “Excel spreadsheet2”, when 

Excel spreadsheet2 is modified the update will be imported to spreadsheet1. The data 

quoted from Excel spreadsheet2 will be updated automatically. 
 

 
 

 
 
If someone create an original Excel table，other persons within the LAN can import this 

Excel table to CAD with AutoXlsTable
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User can calculate block quantities in different layer or in the current drawing or 

according to the properties. The calculation data will be updated if the drawing is 

modified 

 
 
 
●  Photo-Realistic Render - what you see is what you get in 3D mode (Only GstarCAD LT, 

Regular, Premium Professional version have this function) 

 

Advanced rendering module with light source, creation and editing materials,   the   

rendering   background.   Moreover   Render   Window supports the rotation 

and zoom so users can observe the rendering effect dynamically 
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 The Edit of External Reference 
 

Automatically loads the change into all the parent drawings that reference the child 

drawing. 

 

 



 
 
 

GstarCAD 2010 –Fluent Use in Entire Design 
 

www.staricad.com              13         support @staricad.com 
 
 
 
 
 
 

 

 
 
 

 
 

 Etransmit (GstarCAD LT doesn’t include this function) 

Etransmit helps customers send drawings to others by collecting all of a drawing's 

associated files. It's also an excellent tool when you simply want to move drawings. 
 

 
 
 
 

 
 Aerial View 

View large drawings quickly and freely！ 
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 DWG Preview Plug-in 
 

Very  easy  to  browse  the  thumbnail of  DWG  drawing  with  Windows  

Resource 

Manager and also very convenient to position the drawing. 
 

   
 

3. A brand-new engine, Faster speed！ 

GstarCAD has been optimized to take up less memory and display higher quality 

performance;So the speed increased largely Especially opening, saving, copying, 

moving, rotating, mirroring, editing Blocks or selecting a huge number of objects, 
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1.2. Starting up GstarCAD 

1.2.1. Working in GstarCAD 

（1）Initial Interface of GstarCAD 

 
 Drawing area is used for drawing entities actually.  

 Command area is an area to input commands. 

 Status Bar shows current working state, SNAP, GRID, ORTHO and coordinate 

values. 

 Pull-down menu is used for selecting commands by mouse instead of inputting 

commands by keyboard. 

 Toolbar menu supplies commands as types of picture-type icons, so users can 

quickly execute the commands and edit the location and content of commands. 

Once users press right-button of mouse on Toolbar, Toolbar list will be displayed. 

Then select a Toolbar that users want to display on the screen. 
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(2) Introduce each kind of symbol agreement in GstarCAD commands:  

 “/”: The Division symbol divide up different options of the command, each option 

capital letter expressing abbreviation way, you can input this letter to execute this 

option directly. 

 “<”: The small parenthesis, imply the default input value or current execute the 

option in this parenthesis, if not meet to your requirement, then input the new value. 

 After executing some commands, you can use “Enter”, Space Bar or right-button of 

mouse to repeat the command.  

1.2.2. Using Commands 
GstarCAD provides several methods to execute the command. Here is an example of 

“Drawing Line”. 

(1) Pull-down Menu 

Select “Draw >Line” in Pull-down Menu. 

 
(2) Toolbar 
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Select the “Line” in the “Drawing” Toolbar. 

 
(3) Input commands or shortening commands (Hotkeys) 

Command: _LINE 

Start point of line: (pick P1) 

Angle/Length/< End point>: (pick P2) 

Angle/Length/Follow/Undo/< End point>: (pick P3) 

Angle/Length/Follow/Undo/< End point>: (pick P1) 

Angle/Length/Follow/Undo/< End point>: (Enter) 

 
Use function key 

 F6 key (COORDINATE) 

F6 key is used for ON/OFF the coordinate value. Once you press F6 key, coordinate 

value is ON. If you press it again, coordinate is OFF. When F6 key is ON, coordinate 

value of the crosshair is displayed on the status bar of lower screen. 

 
 F7 key (GRID) 

F7 key is used for ON/OFF the GRIP. When GRIP is ON, uniform grids are displayed 

on the screen 

 F8 key (ORTHO) 

F8 key is used for ON/OFF the Ortho function. When Ortho function is ON, a crosshair 

is moved only horizontally or vertically. 

 F9 key (SNAP)  

Snap function can be used only when Grid is ON. When Snap is ON, the mouse always 

moves on grids. When SNAP is OFF, the mouse moves randomly. 
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1.2.3. Working with Coordinates 
(1) Absolute coordinates 

In the GstarCAD, origin (0, 0) is always at lower-left corner of the screen. Absolute 

coordinates are used to input the coordinate value based on the origin. When you know 

the absolute coordinates of the drawing entity, you use it. 

(Input method) X coordinate value, Y coordinate value. 

 
Command: _LINE 

Start point of line: 3,3   

Angle/Length/<End Point>: 6,3   

Angle/Length/Follow/Undo/<End Point>: 6,6   

Angle/Length/Follow/Undo/<End Point>: 3,6   

Angle/Length/Follow/Undo/<End Point>: 3,3   

Angle/Length/Follow/Undo/<End Point>:   

(2) Relative coordinates 

Relative coordinates are used to input the incremental value of X and Y based on the 

last selected point instead of the origin. 

(Input method) @ X Incremental value, Y incremental value 
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Command: _LINE 

Start point of line: (pick P1) 

Angle/Length/<End Point>: @5,0   

Angle/Length/Follow/Undo/<End Point>: @0,5   

Angle/Length/Follow/Undo/<End Point>: @-5,0   

Angle/Length/Follow/Undo/<End Point>: @0,-5   

Angle/Length/Follow/Undo/<End Point>:   

(3) Relative polar coordinates 

Relative polar coordinates are used to specify the point by using the distance and angle 

based on the reference point.  

(Input method) @distance<ANGLE 

 
Command: _LINE 

Start point of line: (pick P1) 

Angle/Length/<End Point>: @5<0   

Angle/Length/Follow/Undo/<End Point>: @5<90   

Angle/Length/Follow/Undo/<End Point>: @5<180   

Angle/Length/Follow/Undo/<End Point>: @5<270   

Angle/Length/Follow/Undo/<End Point>:   
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Chapter 2 File (I/O) Commands 

2.1. New/ Newwiz 
1. NEW (Open a new drawing) 

NEW command opens new drawing sheet on the screen as the preparing step of drawing. 

Use “C:\ProgramFiles\GstarCAD 2010 Professional\ICAD” as a template drawing.  

（1）Execution 

Hot key: Ctrl+N 

Pull-down menu: File >New  

Commands: NEW or N  

Toolbar:  

 

 
（2）What’s TEMPLATE drawings?  

When you are drawing, you always make a border-line and a title which are written in 
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the drawing sheet. If you make them in advance and save as 

“C:\ProgramFiles\GstarCAD 2010 Professional\\Templates ICAD.dwt”, you don’t need 

to make them again because pre-defined ICAD.dwt is automatically opened whenever 

the GstarCAD is started. This kind of drawing sheets that are made by using NEWWIZ 

command, are called as a TEMPLATE. 

2. NEWWIZ  

NEWWIZ command makes designers setup the specific drawing sheet as TEMPLATE. 

Or by using wizard functions, designers can setup environments of the drawing sheet 

such as the sheet size, unit, text size, etc. 

Command: NEWWIZ  

（1）The method of using TEMPLATE 

 
 After selecting “Use a template drawing”, click “Next”.  

 
 Currently default TEMPLATE is set to icad.dwt. If the users want to set other 

drawing sheet as TEMPLATE, click “Browse” button. 
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 Double-click the specific file as a TEMPLATE drawing sheet, or click the file and 

click “Open” button. 

 
 Click the “Finish” button. 

（2）The method of using wizard 

 
 After selecting “Create an entirely new drawing”, click the “Next” button.  
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 Click the “Next” button. 

 
 Select linear units for drawing. Usually “Decimal” is default. 

 Click the “Next” button. 

 Select angular units for drawing. Usually “Decimal” is default. 

 Click the “Next” button. 

 
 Click the “Next” button. 
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 Set ON/OFF of Grid, Snap, UCS Icon and Blips functions. 

 Select the line-type to be used for drawing in “Entity Linetype”. 

 Once you click the “Select Color” button, select the color to be used for drawing. 

 
 Click “Finish” button and end the wizard. 

2.2. Open 
You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design Web 

Format™ (.dwf) files, and drawing template (.dwt) files. 

You can also open and check files that you suspect whether it was damaged.  

Hot key: Ctrl+O 

Command: OPEN or O  

Pull-down menu: File> Open  

Toolbar:  
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2.2.1. Open a existing drawing 

Open an existing drawing 

Use one of the following methods:  

Pull-down menu: File > Open.  

Toolbar:   

Command: OPEN or O   

Choose the type of file you want to open.  

Choose the folder containing the desired file.  

Do one of the following:  

 Choose the drawing you want to open, and then click Open.  

 Double-click the drawing you want to open.  

If the drawing requires a password, enter the password, click OK to verify the password, 

and then click Open again. 

2.2.2. Open damaged drawings 

Files may be damaged for many reasons. GstarCAD allows you to check and recover 

damaged files. 

Open a damaged file 

Use one of the following methods:  

Pull-down menu: File >Drawing utilities >Recover.  

Command: RECOVER  
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Choose the type of file you want to recover. 

Choose the directory containing the damaged file.  

Choose the damaged file you want to recover.  

Click Open.  

To check a drawing file for errors 

If you want to check the opening drawing, do one of the following:  

Pull-down menu: File >Drawing utilities> Audit.  

Command: AUDIT 

Choose whether you want GstarCAD to fix any found errors automatically, and then 

press Enter.  

2.3. Save/ Qsave/Save As 
SAVE or SAVEAS commands make users save the file during working or after finishing 

drawing. When you save a drawing, your work is saved in a drawing (.dwg) file.  

2.3.1. Save a drawing 

Hot key: Ctrl+S 

Pull-down menu: File>Save 

Toolbar:  

Command:  SAVE 
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 If you have saved your drawing for the first time, you can save it with a new name. 

In addition to drawing (.dwg) files, you can also save a drawing in a Drawing Exchange 

Format (.dxf) file or a drawing template (.dwt) file.  

 If you created your drawing using a template, saving the drawing does not alter the 

original template. 

 If you need protect your drawing files, you can save the drawing with a password 

so only you and those who know the password can open the drawing. 

2.3.2. Save a drawing with a new name or file format  

Hot key: Ctrl+Shift+S 

Pull-down menu: File> Save as  

Command: SAVE AS 

Specify the name of the file you want to create 

In the “Save drawing As” dialog box, choose the file format. 

2.4. Export 
EXPORT command is used to save the current drawing as a new file name or other file 

types. Usage is the same with the “SAVE” dialog box. 

Pull-down menu: File> Export 

Command: EXPORT   
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2.5. eTransmit 
(GstarCAD LT Standard and Professional version don’t include this function) 

With eTransmit, you can package a set of files for Internet transmission. Drawing files 

in the transmittal package automatically include all related dependent files such as xrefs 

and font files. 

Pull-down menu: File>E-Transmit 

Command:ETRANSMIT 
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Chapter 3 Draw Geometric Objects 
Drawings are made up of objects. In general, you draw objects by specifying points 

with the pointing device or by entering coordinate values at the command prompt. 

You can create a range of objects, from simple lines and circles to spline curves, 

and ellipses. In general, you draw objects by specifying points with the pointing device 

or by entering coordinate values at the command prompt. 

 Draw Linear Objects  

A line, the most basic object, can be one segment or a series of connected segments. 

 Draw Curved Objects  

Curved objects are arcs, circles, polyline arcs, donuts, ellipses, and splines. 

 Draw Construction and Reference Geometry  

Construction lines and reference points are temporary objects you create to help you 

draw accurately. 

 Create and Combine Areas (Regions)  

Regions are two-dimensional enclosed areas that have physical properties such as 

centroids or centers of mass. You can combine existing regions into a single, complex 

region to calculate area. 

 Create Revision Clouds  

Revision clouds are polylines that consist of sequential arcs. They are used to call 

attention to parts of a drawing during the review stage. 

3.1. Line 
Pull-down-menu: Draw >Line 

Command: LINE or L  

Toolbar:  
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With the Line command you can draw a simple line from one point to another. When 

you pick the first point and move the crosshair to the location of the second point you 

will see a rubber band line which shows you where the line will be drawn when the 

second point is picked. Line objects have two ends (the first point and the last point). 

You can continue picking points and GstarCAD will draw a straight line between each 

picked point and the previous point. Each line segment drawn is a separate object and 

can be moved or erased as required. To end this command, just press the Space bar or 

Enter key on the keyboard. 

Command: line 

Specify first point: (pick P1) 

Specify next point or [undo]: (pick P2) 

Specify next point or [undo]:  (to end) 

 
You can also draw lines by entering the co-ordinates of their end points at the command 

prompt rather than picking their position from the screen . This enables you to draw 

lines that are off screen, should you want. You can also draw lines using something 

called direct distance entry. 

3.2. Construction line 
Pull-down menu: Draw >Construction line 
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Toolbar:  

Command: Xline  

 
The Construction Line command creates a line of infinite length which passes through 

two picked points. Construction lines are very useful for creating construction 

frameworks or grids within which to design. 

Construction lines are not normally used as objects in finished drawings, it is usual, 

therefore, to draw all your construction lines on a separate layer which will be turned off 

or frozen prior to printing. Because of their nature, the Zoom Extents command option 

ignores construction lines. 

Command Sequence 

Command: XLINE 

Specify a point or [Hor/Ver/Ang/Bisect/Offset]: (pick a point) 

Specify through point: (pick a second point) 

Specify through point:  (to end or pick another point) 

You may notice that there are a number of options with this command. For example, the 

"Hor" and "Ver" options can be used to draw construction lines that are truly horizontal 

or vertical. In both these cases, only a single pick point is required because the direction 

of the line is predetermined. To use a command option, simply enter the capitalized part 

of the option name at the command prompt. Follow the command sequence below to 

see how you would draw a construction line using the Horizontal option. 

Command Sequence 

Command: XLINE 

Hor/Ver/Ang/Bisect/Offset/<From point>: H 
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Through point: (pick a point to position the line) 

Through point: (to end or pick a point for another horizontal line) 

3.3. Ray  
Pull-down menu: Draw >Ray  

Command: RAY  

 
The Ray command creates a line similar to a construction line except that it extends 

infinitely in only one direction from the first pick point. The direction of the Ray is 

determined by the position of the second pick point. 

Command Sequence 

Command: RAY 

Specify start point: (pick the start point) 

Specify through point: (pick a second point to determine direction) 

Specify through point:  (to end or pick another point) 

3.4. Polyline  
Pull-down menu: Draw >Polyline  

Toolbar:  

Command: Pline or PL 
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A polyline is a connected sequence of segments created as a single object. You can 

create straight line segments, arc segments, or a combination of the two. In practice the 

Polyline command works in the same way as the Line command allowing you to pick as 

many points as you like. Follow the command sequence below to see how this works.  

Polylines are ideal for applications including the following: 

 Contour lines for topographic, isobaric, and other scientific applications  

 Wiring diagrams and printed circuit board layouts  

 Process and piping diagrams  

 Extrusion profiles and extrusion paths for 3D solid modeling 

Polylines can be created with several commands including PLINE, RECTANG, 

POLYGON, DONUT, BOUNDARY, and REVCLOUD. All of these commands result in 

a LWPOLYLINE (lightweight polyline) object type. Command Sequence 

Command: PLINE 

Specify start point: (pick P1) 

Current line-width is 0.0000 

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: (pick P2) 

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: (pick P3) 

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: (pick P4) 

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: (pick P5) 

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]:  (or C to close) 
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You can draw polylines of various widths by using the Width and Halfwidth 

options. You can set the width of individual segments and make them taper gradually 

from one width to another. These options become available after you specify a starting 

point for the polyline. 

It is worth while taking some time to familiar with the Polyline command as it is 

an extremely useful command to know. Try experimenting with options such as Arc and 

Width and see if you can create polylines like the ones in the illustration above. The 

Undo option is particularly useful. This allows you to unpick polyline vertices, one at a 

time so that you can easily correct mistakes. 

Polylines can be edited after they are created to, for example, change their width. You 

can do this using the PEDIT command, Modify>Object>Polyline from the pull-down 

menu. 

3.5. 3D Polyline 
Pull-down menu: Draw>3D Polyline  

Command: 3DPOLY  
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The 3D Polyline command works in exactly the same way as the Polyline command. 

The main difference between a normal polyline and a 3D polyline is that each vertex 

(pick point) of a 3D polyline can have a different value for Z (height). In normal (2D) 

polylines, all vertexes must have the same Z value. 

3.6. Spline  
Pull-down menu: Draw>Spline  

Toolbar:   

Command: SPLINE or SPL 

 
The Spline command creates a type of spline known as a nonuniform rational B-spline, 

NURBS for short. A spline is a smooth curve that is fitted along a number of control 

points. The Fit Tolerance option can be used to control how closely the spline conforms 

to the control points. A low tolerance value causes the spline to form close to the control 

points. A tolerance of 0 (zero) forces the spline to pass through the control points. The 

illustration on the right shows the effect of different tolerance values on a spline that is 

defined using the same four control points, P1, P2, P3 and P4. 

Splines can be edited after they have been created using the SPLINEDIT command, 

Modify>Object>Spline from the pull-down menu. Using this command, you can change 

the tolerance, add more control points move control points and close splines, amongst 

other things. However, if you just want to move spline control points, it is best to use 

grips.  
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Command Sequence 

Command: SPLINE 

Specify first point or [Object]: (Pick P1) 

Specify next point: (Pick P2) 

Specify next point or [Close/Fit tolerance] <start tangent>: (Pick P3) 

Specify next point or [Close/Fit tolerance] <start tangent>: (Pick P4) 

Specify next point or [Close/Fit tolerance] <start tangent>:  

Specify start tangent: (pick a point) 

Specify end tangent: (pick a point) 

You can create linear approximations to splines by smoothing polylines with the PEDIT 

command, Modify>Object>Polyline from the pull-down menu 

3.7. Circle  
Pull-down menu: Draw >Circle  

Toolbar:  

Command line: CIRCLE or C 
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The Circle command is used to draw circles. There are a number of ways you can define 

the circle. The default method is to pick the center point and then to either pick a second 

point on the circumference of the circle or enter the circle radius at the keyboard. 

Command Sequence 

Command: CIRCLE 

[TwoPoints(2P)/ThreePoints(3P)/Tangency-Tangency-Radius(T)/Arc/Multiple]<Center 

of circle>:(pick P1) 

[Diameter/Radius]<Radius> <17.4439>: (pick P2 or enter the exact radius) 

 

3.8. Arc  
Pull-down menu location: Draw >Arc 

Toolbar:   

Command line: ARC(A) 
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The Arc command allows you to draw an arc of a circle. There are numerous ways to 

define an arc, the default method uses three pick points, a start point, a second point and 

an end point. Using this method, the arc will start at the first pick point, pass through the 

second point and end at the third point. Once you have mastered the default method try 

some of the others. You may, for example need to draw an arc with a specific radius. All 

of the Arc command options are available from the pull-down menu. 

Command Sequence 

Command: ARC 

Specify start point of arc or [Center]: (pick P1) 

Specify second point of arc or [Center/End]: (pick P2) 

Specify end point of arc: (pick P3) 

It is also possible to create an arc by trimming a circle object. In practice, many arcs are 

actually created this way.  

 
 

3.9. Donut 
Pull-down menu: Draw >Donut  

Command: DONUT 
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This command draws a solid donut shape, actually it's just a closed polyline consisting 

of two arc segments which have been given a width. GstarCAD asks you to define the 

inside diameter i.e. the diameter of the hole and then the outside diameter of the donut. 

The donut is then drawn in outline and you are asked to pick the center point in order to 

position the donut. You can continue picking center points to draw more donuts or you 

can hit to end the command. Surprisingly, donuts are constructed from single closed 

polylines composed of two arc segments which have been given a width. Fortunately 

GstarCAD works all this out for you, so all you see is a donut. 

Command Sequence 

Command: DONUT 

Specify inside diameter of donut <0.5000>: (pick any two points to define a diameter or 

enter the exact length) 

Specify outside diameter of donut <1.0000>: (pick any two points to define a diameter 

or enter the exact length) 

Specify center of donut or <exit>: (pick P1) 

Specify center of donut or <exit>:  (to end or continue to pick for more doughnuts) 

 

3.10. Ellipse  
Pull-down menu: Draw >Ellipse  

Toolbar:  

Command: ELLIPSE or ELL 
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The Ellipse command gives you a number of different creation options. The default 

option is to pick the two end points of an axis and then a third point to define the 

eccentricity of the ellipse. After you have mastered the default option, try out the others. 

Command Sequence 

Command: ELLIPSE 

Specify axis endpoint of ellipse or [Arc/Center]: (pick P1) 

Specify other endpoint of axis: (pick P2) 

Specify distance to other axis or [Rotation]: (pick P3) 

The ellipse command can also be used to draw isometric circles 

 

3.11. Ellipse Arc 
Pull-down menu: Draw >Ellipse Arc 

Toolbar:  

Command: ELLIPSE or A 

The Ellipse Arc command is very similar to the Ellipse command, described above. The 

only difference is that, in addition to specifying the two axis end points and the 

"distance to other axis" point, you are prompted for a start and end angle for the arc. 

You may specify angles by picking points or by entering values at the command prompt. 
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Remember that angles are measured in an anti-clockwise direction, starting at the 3 

o'clock position. 

In truth, the Ellipse Arc command is not a new or separate command; it is just an option 

of the Ellipse command and it therefore has no unique command line name. It is curious 

why Autodesk considered this option important enough to give it it's own button on the 

Draw toolbar. Still, there it is. 

Command Sequence 

Command: ELLIPSE 

Specify axis endpoint of ellipse or [Arc/Center]: A 

Specify axis endpoint of elliptical arc or [Center]: (pick P1) 

Specify other endpoint of axis: (pick P2) 

Specify distance to other axis or [Rotation]: (pick P3) 

Specify start angle or [Parameter]: 270 

Specify end angle or [Parameter/Included angle]: 90 

 

3.12. Point  
Pull-down menu: Draw >Point 

Toolbar:  

Command: POINT or P 
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Point objects are useful as nodes or reference geometry for object snaps and relative 

offsets.  

You can set the style of the points and their size relative to the screen or in absolute 

units. Changing the style of points  

 Make them more visible and easier to differentiate from grid dots  

 Affect the display of all point objects in the drawing  

 Require using REGEN to make the change visible  

Command Sequence 

Command: POINT 

Specify a point: (pick any point) 

Set Point Style  

Pull-down: Format>Point Style…  

Command: DDPTYPE  

To change the point style, just pick the picture of the style you want and then click the 

"OK" button. You will need to use the Regen (or RE) command. Any new points created 

after the style has been set will automatically display in the new style. 

One interesting aspect of points is that their size can be set to an absolute value or 

relative to the screen size, expressed as a percentage. The default is for points to display 

relative to the screen size, which is very useful because it means that points will remain 

the same size, irrespective of zoom factor. This is particularly convenient when 

drawings become complex and the drawing process requires a lot of zooming in and out 
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3.13. Rectangle 
Pull-down menu: Draw >Rectangle 

Toolbar:  

Command: RECTANGLE or REC 

The Rectangle command is used to draw a rectangle whose sides are vertical and 

horizontal. The position and size of the rectangle are defined by picking two diagonal 

corners. The rectangle isn't really an GstarCAD object at all. It is, in fact, just a closed 

polyline which is automatically drawn for you. 

Command Sequence 

Command: RECTANG 

[Chamfer/Elevation/Fillet/Rotated/Square/Thickness/Width] or <Select first corner of 

rectangle>:(pick P1) 

Other corner of rectangle: (pick P2) 

 
The Rectangle command also has a number of options. Width works in the same way as 

for the Polyline command. The Chamfer and Fillet options have the same effect as the 

Chamfer and Fillet commands,  
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3.14. Polygon  
Pull-down menu: Draw >Polygon 

Toolbar:  

Command line: POLYGON or POL 

The Polygon command can be used to draw any regular polygon from 3 sides up to 

1024 sides. This command requires four inputs from the user, the number of sides, a 

pick point for the center of the polygon, whether you want the polygon inscribed or 

circumscribed and then a pick point which determines both the radius of this imaginary 

circle and the orientation of the polygon. The polygon command creates a closed 

polyline in the shape of the required polygon. 

This command also allows you to define the polygon by entering the length of a side 

using the Edge option. You can also control the size of the polygon by entering an exact 

radius for the circle. Follow the command sequence below to see how this command 

works. 

Command Sequence 

Command: POLYGON 

[Multiple/Width of line]<Number of sides> <5>: 

Specify by:  [Edge]<Center of polygon>:e 

First endpoint of edge: P1 

Second endpoint of edge: P2 

 

3.15. Multiline 
Pull-down menu: Draw >Multiline 

Command: MLINE 

The Multiline command is used to draw multilines. This process of drawing is pretty 

much the same as drawing polylines, additional line segments are added to the multiline 
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as points are picked. As with polylines, points can be unpicked with the Undo option 

and multilines can be closed. 

When you start the Multiline command you also have the option to specify the 

Justification, Scale and Style of the multiline. The Justification option allows you to set 

the justification to "Top", the default, "Zero" or "Bottom". When justification is set to 

top, the top of the multiline is drawn through the pick points, as in the illustration below. 

Zero justification draws the center line of the multiline through the pick points and 

Bottom draws the bottom line through the pick points. Justification allows you to 

control how the multiline is drawn relative to your setting out information. For example, 

if you are drawing a new road with reference to its center line, then Zero justification 

would be appropriat 

The Scale option allows you to set a scale factor, which effectively changes the width of 

the multiline. The default scale factor is set to 1.0 so to half the width of the multiline, a 

value of 0.5 would be entered. A value of 2.0 would double the width. 

The Style option enables you to set the current multiline style. The default style is called 

"Standard". This is the only style available unless you have previously created a new 

style with the Multiline Style command. Follow the command sequence below to see 

how the Multiline command works and then try changing the Justification and Scale 

options. 

Command Sequence 

Command: MLINE 

Current settings: Justification = Top, Scale = 20.00, Style = STANDARD 

Specify start point or [Justification/Scale/STyle]: (Pick P1) 

Specify next point: (Pick P2) 

Specify next point or [Undo]: (Pick P3) 

Specify next point or [Close/Undo]:  (to end or continue picking or C to close) 
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Set Multiline Style  

Pull-down menu: Format>Multiline Style  

Command: MLSTYLE  

The Multiline style command is used to create new multiline styles, which can then be 

used with the Multiline command. When you start the command for the first time, you 

will see the Multiline Styles dialogue box indicating that the Standard style is "Current". 

To create a new style, click “New”, enter a new style name in the "Name" edit box  

 

 
Then click “Continue”. So the next step is to change the style to suit your own purposes.  
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You will now see the Element Properties dialogue box appear. This dialogue box allows 

you to add new line elements or delete existing ones and to control the element offset, 

color and linetype. Click the "Add" button to add a new element. A new line element 

now appears with an offset of 0.0, in other words, this is a center line. Highlight the top 

element in the "Elements" list and change the offset to 1.0 by entering this value in the 

"Offset" edit box. Now do the same with the bottom element remembering to enter a 

value of -1.0 because this is a negative offset. You now have a multiline that is 2 

drawing units wide with a centerline. Let's now change the color and linetype of the 

center line. 

Highlight the 0.0 offset element by clicking it in the "Elements" list. To change the color, 

simply click on the Color… button and select an appropriate color from the palette. 

When a color has been selected, click the "OK" button on the palette to return to the 

Element Properties dialogue box. 

Changing the linetype is a little more complicated because we will need to load the 

required linetype first. However, click on the "Linetype…" button to proceed. 

The Select Linetype dialogue box appears with just a few solid linetypes listed, ByLayer, 

ByBlock and Continuous. Click on the "Load…" button. The Load or Reload Linetypes 

dialogue box now appears. Scroll down the list of linetypes until you find one called 

"Hidden". Highlight Hidden and then click the "OK" button. You will now see the 

Hidden linetype appear in the "Loaded linetypes" list in the Select Linetype dialogue 

box, which should now look similar to the one shown above. Finally, highlight Hidden 

and click the "OK" button. Your Element Properties dialogue box should now look 

similar to the one in the illustration above. To complete our new style, we will add some 

end caps and a solid fill. Click on the "Multiline Properties…" button to proceed. 

In the Multiline Properties dialogue box, click in the "Line" check boxes under "Start" 

and "End". This will have the effect of capping the ends of the multiline with a 90 

degree line. As you can see from the dialogue box, you can change this angle if you 

wish to give a chamfered end. Next, click the "On" check box in the "Fill" section and 

then click on the Color button and select the fill color from the palette. The Multiline 

Properties dialogue box should now look like the one in the illustration on the left. 

Finally, click the "OK" button in the Multiline Properties dialogue box and again in the 

Multiline Style dialogue box. You are now ready to draw with your new multiline. 
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3.16. Revision Cloud  
Pull-down menu: Draw>Revision Cloud 

Toolbar:  

Command line: REVCLOUD 

The Revcloud command is used to draw a "freehand" revision cloud or to convert any 

closed shape into a revision cloud. 

Command Sequence 

Command: REVCLOUD 

Minimum arc length: 15   Maximum arc length: 15   Style: Normal 

Specify start point or [Arc length(A)/Object/Style] <Object>:(Pick P1) 

Guide crosshairs along cloud path... 

Move the mouse to form a closed shape; the command automatically ends when a 

closed shape is formed. 

Revision cloud finished. 

You can use the "Arc length" option to control the scale of the revision cloud. This is 

achieved by specifying the minimum and maximum arc length. The "Object" option is 

used to transform any closed shape, such as a polyline, spline or circle into a revision 

cloud. You can use “Style” option set the style as Normal or Calligraphy 。 
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3.17. Region 
Pull-down menu: Draw >Region  

Toolbar:  

Command: REGION 

A region is a surface created from objects that form a closed shape, known as a loop. 

The Region command is used to transform objects into regions rather than actually 

drawing them (i.e. you will need to draw the closed shape or loop first). Once a region 

is created, there may be little visual difference to the drawing.  

Before starting the Region command, draw a closed shape such as a rectangle, circle or 

any closed polyline or spline. 

Command Sequence 

Command: REGION 

Select objects: (Pick P1)  

1 region have been created 

 

3.18. Hatch 
You can hatch an area using a predefined hatch pattern, define a simple line pattern 

using the current linetype, or create more complex hatch patterns. One type of pattern is 

called solid, which fills an area with a solid color. 

You can also create a gradient fill, which uses a transition between shades of one color 

or between two colors. Gradient fills can be used to enhance presentation drawings, 

giving the appearance of light reflecting on an object. 

Pull-down menu: Draw> Hatch 
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Toolbar:  

Command: BHATCH  

The usage of hatch 

Command: _BHATCH 

 
 Firstly, in order to determine the type of hatching lines, select proper hatching 

patterns in the “Pattern” tab. 

 
If you select “SOLID” in the “Pattern” tab, then click “OK” button. 

 In order to change scale and angle, input the value of “Scale” and “Angle” in the 

“Hatch” tab. 
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●  In order to do hatching, if you select "Pick Points " button in the "Hatch" tab, pick 

an internal point of hatching area; if you select "Select Objects " button in the "Hatch" 

tab, pick the boundary of hatching area. 

Ⅰ”Pick Points: 

Select a point to define a boundary or hatch area: (pick P1) 

Select a point to define a boundary or hatch area: (pick P2) 

Select a point to define a boundary or hatch area: (pick P3) 

Select a point to define a boundary or hatch area: 

 
Then press “OK” in the “Hatch” tab. 
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Ⅱ"Select Objects " 

Select entities:(select S1)  

Select entities:(select S2) 

Select entities:(select S3) 

Select entities: 

 
Then press “OK” in the “Hatch” tab. 
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3.19. Wipeout  
Pull-down menu: Draw>Wipeout  

Command: WIPEOUT   

A Wipeout is an image type object. Most commonly it is used to "mask" part of a 

drawing for clarity. For example, you may want to add text to a complicated part of a 

drawing. A Wipeout could be used to mask an area behind some text so that the text can 

easily be read, as in the example shown on the right. 

 

 
The Wipeout command can be used for 3 different operations. It can be used to draw a 

wipeout object, as you might expect, but it can also be used to convert an existing 

closed polyline into a wipeout and it can be used to control the visibility of wipeout 

frames. 

Command Sequence 

Command: WIPEOUT 

Specify first point or [Frames/Polyline] <Polyline>: (Pick P1) 

Specify next point: (Pick P2) 

Specify next point or [Undo]: (Pick P3) 

Specify next point or [Close/Undo]: (Pick P4) 

Specify next point or [Close/Undo]: 

 
You can use as many points as you wish in order to create the shape you need. When 

you have picked the last point, use right-click and Enter (or hit the Enter key on the 

keyboard) to complete the command and create the wipeout. 
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You may find that it is easier to draw a polyline first and then convert that polyline into 

a wipeout. To do this, start the Wipeout command and then Enter to select the default 

"Polyline" option. Select the polyline when prompted to do so. Remember, polylines 

must be closed before they can be converted to wipeouts. 

 

3.20. Block 
Block is a combination of several entities and is treated as one entity by inserting it into 

a drawing. Block consists of visual entities such as lines, arcs and circles and attributes 

of them. It is saved as part of the drawing file.When you use Block, you can make the 

drawing quickly and reduce the file size. If you make common-used symbols into 

libraries, you can make the symbols by inserting BLOCK without drawing them again 

from first. 

1. Create block 

Pull-down menu: Draw >Block >Make 

Command: BLOCK   

Toolbar:  

After you drawing the following drawing on the screen, set them as BLOCK. 

 

 

 

 

 Set the drawing as BLOCK. 

Command: _BLOCK 
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Press “Select” button. 

Select entities for block: (pick P1) 

Opposite corner: (pick P2) 

Select entities for block: 

 
 Then input the name of the block, press “OK” button. 

 
2. WBLOCK   

Insert a BLOCK that is created by BLOCK command into the current drawing. 

Command: WBLOCK   

The usage of Wblock 
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Command: WBLOCK 

 

 
Select entities for block: (pick P1) 

Opposite corner: (pick P2) 

Select entities for wblock:  

3. Insert block 

Inserting block is used to insert the BLOCK that is created by WBLOCK command or 

other external drawings into the current drawing. 

Pull-down menu: Insert>Block 

Command: INSERT or DDINSERT  

Toolbar:  

 Select the BLOCK or other external drawings to insert. 

 Input the insertion point of BLOCK, scale factor and rotation angle. When you 

select “Position block when inserting", you can’t input the parameters. In that case, you 

can input the parameters when you insert BLOCK into the screen. 

When you select "Explode block upon insertion", BLOCK is inserted as exploded 
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entities instead of one entity. 
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Chapter 4 Modifying Entities 
Introduction 

Drawings are rarely completed simply by drawing lines, circles etc. Most likely you will 

need to modify these basic drawing objects in some way in order to create the image 

you need. GstarCAD provides a whole range of modify tools such as Move, Copy, 

Rotate and Mirror. As you can see, the command names are easily understandable. If 

you just need information quickly, use the toolbar below to go straight to the 

information you need. 

 

4.1. The Erase Command 
Pull-down menu: Modify>Erase  

Toolbar:  

Command: ERASE or E 

 
The Erase command is one of the simplest commands and is one of the most used. The 

command erases (deletes) any selected object(s) from the drawing. Remember you can 

always get deleted objects back by typing U or undo, from the Standard toolbar or by 

using the OOPS command. 

Command Sequence 

Command: ERASE 

Select objects: (select objects to delete) 

Select objects: (to end the selection and erase the object) 

If you simply want to erase the last object you created you can type L at the "Select 
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objects" prompt. The last object will be highlighted and you can then select more 

objects or to end the command.  

4.2. The Copy Command 
Pull-down menu: Modify>Copy  

Toolbar:   

Command line: COPY or CP  

 
The Copy command can be used to create one or more duplicates of any drawing object 

or objects which you have previously created. Copy is a very useful and time-saving 

command because you can create very complex drawing elements and then simply copy 

them as many times as you like. 

 
Command Sequence 

Command: COPY 

Select objects: (pick object to copy, P1) 

Select objects:  (to end selection) 

Vector/<Base point>: (pick P2) 

Displacement point: (pick P3) 

Notice that the "Base point", P2 and the "Second point", P3 do not have to be picked on 

or near the object. The two points are simply used to indicate the distance and direction 

of the copied object from the original object. 
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4.3. The Mirror Command 
Pull-down menu: Modify>Mirror  

Toolbar:    

Command line:  MIRROR or MI 

 
The Mirror command allows you to mirror selected objects in your drawing by picking 

them and then defining the position of an imaginary mirror line using two points. 

 
Command Sequence 

Command: MIRROR 

Select objects: (pick object to mirror, P1) 

Select objects:  (to end selection) 

Start of mirror line: (pick P2) 

End of mirror line: (pick P3) 

Delete the original entities? <N>  

In order to create perfectly horizontal or vertical mirror lines use Ortho.  

4.4. The Offset Command 
Pull-down menu: Modify>Offset  

Toolbar:   

Command: OFFSET or O 
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Offset is probably one of the most useful commands for constructing drawings. The 

Offset command creates a new object parallel to or concentric with a selected object. 

The new object is drawn at a user defined distance (the offset) from the original and in a 

direction chosen by the user with a pick point. You can offset lines, arcs, circles, ellipses, 

2D polylines, xlines, rays and planar splines. 

Command Sequence 

Command: OFFSET 

Parallel: [Through point]<Distance> <13.2025>:(input distance or use the default value) 

Select objects: (select object, P1) 

[Both sides]<Side for parallel copy>: (pick direction, P2) 

In the illustration below, a line has been offset to the right through a distance "Offset" 

by picking a point to the right of the original line. The result is a new line (red) to the 

right of the original. 

 
Circles can be offset inside or outside of themselves to create a new circle which is 

concentric (has the same center point) with the original circle. In the illustration, a new 

circle (red) has been created outside of the original by picking a point outside of the 

original circle. The radius of the new circle is the offset distance "Offset" plus the radius 

of the original circle. 

In the illustration above, the new objects and original objects are shown in different 
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colors for clarity. In reality, offset objects inherit their object properties from the original 

object.  

4.5. The Array Command 
Pull-down menu: Modify>Array  

Toolbar:  

Command: ARRAY or AR  

 
The Array command makes multiple copies of selected objects in a rectangular matrix 

(columns and rows) or a polar (circular) pattern.  

The Rectangular Array 

    The illustration shows the results of a rectangular array with two columns and three 

rows. The distance between rows is indicated with the dimension DR and between 

columns with DC. When creating rectangular arrays it is important to remember that 

new rows are created above the original object and new columns are created to the right 

of the original object. The resulting array is, therefore, always created with the original 

object in the bottom left hand position with respect to the current co-ordinate system. In 

the illustration, the original object is shown in cyan and the new objects in red. It is 

possible to create arrays which do not align with the World Co-ordinate System by 

setting a User Co-ordinate System first.  
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Now start the Array command. First of all, make sure that the Rectangular Array button 

is selected and that you are looking at the Rectangular Array dialogue box and now 

follow the steps below: 

1. Click the Select objects button. The dialogue box will temporarily disappear enabling 

you to select the rectangle you just drew. Press the Return button on your keyboard to 

complete the selection. You are now returned to the dialogue box and the message 

immediately below the Select Objects button should read "1 objects selected".  

2. Enter the number of rows required in the Rows edit box. For this example, enter the 

value "3". Notice that the schematic preview on the right hand side of the dialogue box 

updates to reflect the values you are entering.  

3. Enter the number of columns required in the Columns edit box. Enter the value "2".  

4. Enter the row offset in the Row Offset edit box. This is the distance DR in the 

illustration above. Note that this is not the distance between rows. In this example, our 

rectangle is 10 units high and we will enter a row offset of 15. The result will be a 5 unit 

gap between rectangles.  
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5. Enter the column offset in the Column Offset edit box. The same parameters apply as 

for the row offset. Enter a value of 25 to give a 5 unit gap between our rectangles.  

6. Click on the Preview button. Once again, the dialogue box disappears and the 

specified array is temporarily drawn so that we can preview it. We are now offered 3 

choices. If the array isn't quite right, click the Modify button to return to the Array 

dialogue box. If you are happy with the array, click the Accept button, the array will be 

permanently drawn and the command is ended.  

 
You should now have an array that looks similar to the one in the illustration above 

consisting of 6 rectangles arranged in 3 rows and 2 columns. As you can see, this 

command is very powerful and can save lots of time if used carefully. 

The Polar Array 

The polar array works in a similar way to the rectangular array. The main difference is 

that rather than specifying the number and offset for rows and columns, you must 

specify a center point and the total number of objects in the array (including the original 

object). 

 
You can try this for yourself by drawing another rectangle as described above. This time, 

though, locate the rectangle in the center top half of the drawing area. Now, start the 

Array command, click the Polar Array radio button and follow the steps below: 

1. Click the Select objects button. The dialogue box will temporarily disappear enabling 

you to select the rectangle you just drew. Press the Return button on your keyboard to 

complete the selection. You are now returned to the dialogue box and the message 
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immediately below the Select Objects button should read "1 object selected".  

2. Specify the center point for the array. This is the point C in the illustration below. You 

can do this by entering x and y co-ordinates into the appropriate edit boxes if you know 

what these values should be. However, this is rarely the case and most often you will 

want to click the Pick Center Point button to pick a point from the drawing area. Pick a 

point somewhere below the rectangle you have just drawn.  

3. Enter a value for the total number of items. For this example, enter the value "6". 

Notice that once again, the schematic preview updates to reflect the values you have 

entered.  

4. Make sure that the rotate items as copied checkbox is checked.  

5. Click on the Preview button. Once again, the dialogue box disappears and the 

specified array is temporarily drawn so that we can preview it. We are now offered 3 

choices. If the array isn't quite right, click the Modify button to return to the Array 

dialogue box. If you are happy with the array, click the Accept button, the array will be 

permanently drawn and the command is ended.  

 
The array you have just drawn should look something like the one illustrated below, left. 

Take some time to play around with the other options in the Array dialogue box to see 

what they can do. 

 
The illustration above shows the results of a polar array using an original rectangle 

copied six times about a center point C, through an angle of 360 degrees (full circle). 

The only difference between the array on the left and the one on the right is that the 

Rotate items as copied checkbox was not checked in the right hand example. 

All new objects created with the Array command will inherit the object properties of the 

original object.  
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4.6. The Move Command 
Pull-down menu: Modify>Move  

Toolbar:   

Command line: MOVE or M  

 
The Move command works in a similar way to the Copy command except that no copy 

is made, the selected object(s) is simply moved from one location to another. 

 
Command Sequence 

Command: MOVE 

Select objects to move: (pick object to move, P1) 

Vector/<Base point>:  (pick P2) 

Displacement point: (pick P3) 

4.7. The Rotate Command 
Pull-down menu: Modify>Rotate  

Toolbar:   

Command: ROTATE or RO 
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The Rotate command allows an object or objects to be rotated about a point selected by 

the user. GstarCAD prompts for a second rotation point or an angle which can be typed 

at the keyboard. 

 
Command Sequence 

Command: ROTATE 

Select objects to rotate: (pick object to rotate, P1) 

Rotation point: (pick base point, P2) 

[Base angle]<Rotation angle>: (pick second point P3 or enter angle) 

4.8. The Scale Command 
Pull-down menu: Modify>Scale  

Toolbar:  

Command: SCALE or SC 
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The Scale command can be used to change the size of an object or group of objects. You 

are prompted for a pick point about which the selection set will be scaled. Scaling can 

then be completed by picking a second point (not always easy because it can sometimes 

be difficult to precisely control the scaling) or by entering a scale factor at the keyboard. 

For example: a scale factor of 2 will double the size of the objects in the selection set 

and a factor of 0.5 will half them. 

 
Command Sequence 

Command: SCALE 

Select objects: (pick objects to be scaled, P1) 

Specify base point: (pick base point, P2) 

[Base scale/Scale factor]<Scale factor>: (pick second point, P3 or enter scale factor) 

In the example shown above, the original tree symbol has been enlarged by dynamically 

scaling it using pick points to determine the change in scale. If you want to scale an 

object precisely, it is much easier to enter a scale factor using the keyboard. 

4.9. The Stretch Command 
Pull-down menu: Modify>Stretch  

Toolbar:   

Command: STRETCH or S  
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The Stretch command can be used to move one or more vertices of an object whilst 

leaving the rest of the object unchanged. In the example below, a rectangle has been 

stretched by moving one vertex to create an irregular shape. 

 
Command Sequence 

Command: STRETCH 

Select objects to stretch by crossing-window or crossing-polygon: 

Specify base point or displacement: (pick base point) 

Specify second point of displacement: (pick second point) 

To select vertices to stretch, you must use a crossing window or polygon.  

Stretching with Grips 

Although the Stretch command can be very useful, it has largely been superseded by the 

use of "Grips" which allow this sort of modification to be made much more intuitively. 

 
To stretch an object using grips, simply select the object by clicking on it (you can do 

this without starting a command). The object becomes highlighted and small square 

grips appear at each vertex and various snap points, depending upon the object type. 

Click a grip to activate it and click again to reposition it. When you have completed 
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your modifications, use the Escape key (Esc) at the top left of your keyboard to deselect 

the object and release grips. 

4.10. The Lengthen Command 
Pull-down menu: Modify>Lengthen  

Command line: LENGTHEN or LEN 

 
The Lengthen command can often be used instead of either the Trim or Extend 

commands. Indeed the end result is exactly the same. The Lengthen command can be 

used to either lengthen or shorten Lines, Arcs, open Polylines, elliptical Arcs and open 

Splines without the use of cutting or boundary edges. 

Command Sequence 

Command: LENGTHEN 

Edit length:  [DYnamic/Increment/Percent/Total]<Select objects to list length>: DY 

Select an object to change or [Undo]: (select a line or arc) 

Specify new end point: (pick new end point) 

Select an object to change or [Undo]:  (to end) 

The command sequence above demonstrates the use of the Dynamic Lengthen option 

which is probably the most useful for general purpose drafting. However, the other 

options are worth getting to know because they can save lots of time and effort. 

The Total option allows you to change the total length of a line to any value that you 

specify. The Percent option allows you to change a line length using a percentage.  

4.11. The Trim Command 
Pull-down menu: Modify>Trim  
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Toolbar:    

Command: TRIM or TR 

 
The Trim command can be used to trim a part of an object. In order to trim an object 

you must draw a second object which forms the "cutting edge". Cutting edges can be 

lines, xlines, rays, polylines, circles, arcs or ellipses. Blocks and text cannot be trimmed 

or used as cutting edges. The illustration on the below shows the Trim command in 

action. The red square and circle have been drawn using the Polygon and Circle 

commands respectively. In order to trim these objects, a line has been drawn (cyan in 

the illustration), this forms the cutting edge. The Trim command, unlike most other 

modify commands requires that two separate object selections are made. The cutting 

edges are selected first (there can be one or more) and then the objects to be trimmed 

are selected. In the example below, the line is selected first because it forms the cutting 

edge and then the square and circle are selected. 

The Trim command is slightly more complicated than many other modify commands. 

To get a better understanding of how it works, draw a square, circle and line as 

illustrated below and then follow the command sequence below. Don't forget to watch 

the command line at each stage of the process. 

 
Command Sequence 
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Command: TRIM 

Select objects or <select all>: (select the cutting edge, P1) 

Select the object to Trim or shift-select to Extend or [Edge/Fence/Project]: (pick the part 

of the square which you want to trim, P2) 

Select the object to Trim or shift-select to Extend or [Edge/Fence/Project/Undo]: (pick 

the circle, P3) 

Notice that at each trimming step you are given the option to undo the previous trim. 

This can be very useful if you inadvertently pick the wrong object. 

4.12. The Extend Command 
Pull-down menu: Modify>Extend  

Toolbar:  

Command: EXTEND or EX 

 

 
This command extends a line, polyline or arc to meet another drawing object (known as 

the boundary edge). In the illustration on the below, two lines (red) are extended to meet 

another line (cyan) which forms the boundary edge. This command works in a similar 

way to the Trim command, described above. Two selections are made, one for the 

boundary edge(s) and one for the object(s) to extend. 

 
 Lines and other objects can be extended in one of two directions. In the illustration on 
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the right, the red line could be extended either to the right or to the left. You can tell 

GstarCAD in which direction to extend by picking a point to the right or left of the 

midpoint respectively. GstarCAD does not intuitively know where the boundary edge 

lies so you must explicitly indicate the direction of extension by picking either one side 

or other of the midpoint. 

Command Sequence 

Command: EXTEND 

Select objects or <select all>: (select the boundary edge, P1) 

Select the object to Extend or shift-select to Trim or [Edge/Fence/Project]: 

Select the object to Extend or shift-select to Trim or [Edge/Fence/Project/Undo]: (pick 

the object which you want to be extended, P2) 

Select the object to Extend or shift-select to Trim or [Edge/Fence/Project/Undo]: (pick 

another object which you want to be extended, P3) 

Sometimes you may get the message "Object does not intersect an edge" or "No edge in 

that direction". If this happens it means that you are either picking the wrong end of the 

object or the object you are trying to extend will not meet the boundary edge. The 

solution is either to pick near the end you want to extend or to move the boundary edge 

so that the extended line will intersect with it. 

4.13. The Break Command 
Pull-down menu:  Modify>Break  

Toolbar:  

Command: BREAK or BR  
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The Break command enables you to break (remove part of) an object by defining two 

break points. In the illustration below, a corner of a rectangle has been removed. The 

Break command can be used with lines, polylines, circles, arcs ,ellipses, splines, xlines 

and rays. When you break an object, you can either select the object using the first break 

point and then pick the second break point, or you can select the object and then pick 

the second break point. 

 
Command Sequence 

Command: BREAK 

 [First break point]<Second break point>: F 

Specify first break point: (pick the first break point P1) 

Specify second break point: (pick the second break point P2) 

The section of the object is removed and the command ends. 

4.14. The Chamfer Command 
Pull-down menu: Modify>Chamfer  

Toolbar:   

Command: CHAMFER or CHA 

 
The Chamfer command enables you to create a chamfer between any two non-parallel 

lines as in the illustration below or any two adjacent polyline segments. Usually, the 
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Chamfer command is used to set the chamfer distances before drawing the chamfer. 

Follow the command sequence below where the chamfer distances are changed to 20 

before the chamfer is made. 

 
Command Sequence 

Command: CHAMFER 

Chamfer dist1=15.0000, dist2=15.0000:  

[Distance/Angle/Trim/mEthod/Polyline/Multiple] <Select first entity>: D 

Chamfer distance on first entity <15.0000>:10 

Chamfer distance on second entity <10.0000>:10 

Chamfer dist1=10.0000, dist2=10.0000:  

[Distance/Angle/Trim/mEthod/Polyline/Multiple] <Select first entity>: (pick P1) 

Select second entity: (pick P2) 

The chamfer is made and the command ends. 

Notice from the command sequence that there are a number of options which can be 

used to control the way the Chamfer command behaves. The Polyline option can be 

used to chamfer all vertexes of a polyline simultaneously. The Distance option allows 

you to specify the two chamfer distances. Angle allows the angle between the first line 

and the chamfer to be specified. Trim is used to control whether the original lines are 

trimmed to the chamfer or remain as they are. Finally, Method is used to toggle the 

command between Distance and Angle mode. When Angle mode is used, the chamfer is 

defined using one distance and an angle rather than two distances. 

4.15. The Fillet Command 
Pull-down menu: Modify>Fillet  

Toolbar:  

Command: FILLET or F  
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The Fillet command is a very useful tool which allows you to draw an arc between two 

intersecting lines or adjacent polyline segments. You first need to use the command to 

set the required radius and then select the two lines. 

Command Sequence 

Command: FILLET 

Fillet radius=25.0000:  [Radius/Polyline/Trim/Multiple]<Select first entity>:R 

Fillet radius <25.0000>:10 

Fillet radius=10.0000:  [Radius/Polyline/Trim/Multiple]<Select first entity>:(pick P1) 

Select second entity: (pick P2) 

The Fillet command can also be used to fillet arcs and circles. The "Polyline" option 

also allows you to fillet all vertices of a polyline with a single command.  

For example, you can easily create the lozenge shape shown on the below from a simple 

rectangle. Since rectangles are just closed polylines, you can use the Polyline option of 

the Fillet command to fillet all polyline vertexes simultaneously.  

 



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 77

 
Command Sequence 

Command: FILLET 

Fillet radius=10.0000:  [Radius/Polyline/Trim/Multiple]<Select first entity>: P 

Select 2D polyline to fillet: (pick P1) 

4 lines were filleted 

Tip: Make sure that the radius you specify will fit the objects you select, otherwise the 

fillet command will not work. 

4.16. The Explode Command 
Pull-down menu: Modify>Explode  

Toolbar:  

Command: EXPLODE  

 
The Explode command is used to "explode" single object back to their constituent parts. 

In other words, the command is used to return blocks, polylines etc. (which may be 

composed of a number of component objects) back to their individual component parts. 

The change has no visible effect. 

4.17. Undo 
With UNDO command, Users can inversely cancel executed commands step by step or 
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user-defined number of steps. Undo command is unlimited time undo. 

Pull-down menu: Edit >Undo 

Toolbar:  

Command : UNDO or U   

 

4.18. Redo 
REDO command is used to restore canceled commands by UNDO step by step. Redo 

command is unlimited time redo. 

Pull-down Menu: Edit → Redo 

Toolbar:  

Command : REDO   

 
Commands that are canceled by UNDO previously, can be restored by REDO 

command. 
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Chapter 5 Viewing Entities 

5.1. Redraw 
Refresh the display in all viewports 

Pull-down menu: View>Redraw 

Command : REDRAW or REDRAWALL or R   

 
When BLIPMODE is on, marker blips left by editing commands are removed from all 

viewports.  

 

5.2. Regen 
Regenerate the drawing and refresh all viewports 

Pull-down menu: View> Regen 

Commands: REGEN or REGENALL  
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REGENALL regenerates the entire drawing and recomputes the screen coordinates for 

all objects in all viewports. It also reindexes the drawing database for optimum display 

and object selection performance. 

 

5.3. Zoom 
Increase or decrease the apparent size of objects in the current viewport 

Pull-down menu: View Zoom  

Toolbar:  

Commands: ZOOM or Z  
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ZOOM: 

[All/Center/Dynamic/Extents/Previous)/In/Out/Left/Right/Window/Scale(nX/nXP)] 

<Real Time> 

The usage of zoom 

All  

Zoom to display the entire drawing in the current viewport. In a plan view, All zooms to 

the grid limits or current extents, whichever is greater. In a 3D view, ZOOM All is 

equivalent to ZOOM Extents. The display shows all objects even if the drawing extends 

outside the grid limits. 

 
In the illustration, LIMITS is greater than the extents of the drawing.  

Center  

Zoom to display a window defined by a center point and a magnification value or height. 

A smaller value for the height increases the magnification. A larger value decreases the 

magnification. 
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Dynamic  

Zoom to display the generated portion of the drawing with a view box. The view box 

represents your viewport, which you can shrink or enlarge and move around the 

drawing. Positioning and sizing the view box pans or zooms to fill the viewport with the 

image inside the view box. 

 
The panning view box is displayed first. Drag it to the location you want and click. The 

zooming view box is then displayed. Resize it and press ENTER to zoom, or click to 

return to the panning view box. 

Press ENTER to fill the current viewport with the area currently enclosed by the view 

box. 

Extents  

Zoom to display the drawing extents and result in the largest possible display of all the 

objects. 

 
Previous  

Zoom to display the previous view. You can restore up to 10 previous views. 
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Note: If you change the visual style, the view is changed. If you enter ZOOM Previous, 

it restores the previous view, which is shaded differently but not zoomed differently. 

Scale  

Zoom the display at a specified scale factor. 

Enter a scale factor (nX or nXP): Specify a value 

Enter a value followed by x to specify the scale relative to the current view. For 

example, entering .5x causes each object to be displayed at half its current size on the 

screen. 

 

5.4. Pan 
PAN is used to move the view in the current viewport 

Pull-down menu: View>Pan 

Toolbar:  

Commands: PAN or P   
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The usage of pan  

When you use wheel-mouse, you can use “PAN” function by pressing the wheel of the 

mouse. Then a mouse icon is changed like a hand. If you want to use the wheel for 

panning, the value of button pan should be “on”. 

 

5.5. Aerial View 
In a large drawing, you can pan and zoom quickly in a window that can display the 

whole drawing. 

Within the Aerial View window is a view box, a heavy rectangle that displays the 

boundary of the view in your current viewport. You can change the view in the drawing 

by changing the view box in the Aerial View window. To zoom in to the drawing, make 

the view box smaller. To zoom out of the drawing, make the view box larger. All pan 

and zoom operations are performed by left-clicking. Right-click to end a pan or zoom 

operation.  

Pull-down menu: View>Aerial View 

Commands: dsviewer 
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5.6. Visual Style 
(GstarCAD Regular Standard version doesn’t include the following functions) 

A visual style is a collection of settings that control the display of edges and shading in 

the viewport. Instead of using commands and setting system variables, you change the 

properties of the visual style. As soon as you apply a visual style or change its settings, 

you can see the effect in the viewport. 

Pull-down menu: View>Visual style 

 
 2D Wireframe: Display the objects using lines and curves to represent the 

boundaries, Raster and OLE objects. linetypes, and lineweights are visible.  

 3D Wirefram: Display the objects using lines and curves to represent the 

boundaries.  
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 3D Hidden: Display the objects using 3D wireframe representation and hides lines 

representing back faces.  

 

5.7. Viewports 
Create layout viewports 

Pull-down menu: View>Viewports 

Command: MVIEW 

 
The usage of viewports 
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Command: MVIEW 

Viewports: [ON/OFF/Fit/2/3/4/Polygon/Object] <First corner>: 

Corner of Viewport 

Specify the first corner of a rectangular viewport. 

Specify opposite corner 

On 

Make a selected viewport active. An active viewport displays objects in model space. 

The MAXACTVP system variable controls the maximum number of viewports that can 

be active at one time. If your drawing contains more viewports than the number 

specified in MAXACTVP, you must turn one off to make another one active.  

Select objects: Select one or more viewports 

Off 

Make a selected viewport inactive. Objects in model space are not displayed in an 

inactive viewport.  

Select objects: Select one or more viewports 

Fit 

Create one viewport that fills the layout to the edges of the printable area. When the 

paper background and printable area are turned off, the viewport fills the display. 

 
Polygon 

Create an irregularly shaped viewport using specified points. The prompts are similar to 

those displayed when you specify a polygonal clip boundary for external references, but 

you can specify arcs when you create a polygonal viewport boundary. 

Viewports: [ON/OFF/Fit/2/3/4/Polygon/Object]<First corner>:P 

ENTER to use last point [Follow] <Start of polyline>: 

[Arc/Distance/Follow/Halfwidth/Width]<Next point>: 

Object 

Specify a closed polyline, ellipse, spline, region, or circle to convert into a viewport. 

The polyline you specify must be closed and contain at least three vertices. It can be 
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self-intersecting, and it can contain an arc as well as line segments. 

Select object to clip viewport: Select an object 

2 

Divide the specified area horizontally or vertically into two viewports of equal size. 

Enter viewport arrangement [Horizontal/Vertical] <Vertical>: Enter h or press Enter 

Specify first corner: Specify a point or press ENTER 

                              
First Corner  

Position and size new viewports using the window selection method; the viewports are 

fit into the selected area. 

3 

Divide the specified area into three viewports. 

Enter viewport arrangement 

[Horizontal/Vertical/Above/Below/Left/<Right>: Enter an option or press ENTER 

The Horizontal and Vertical options split the specified area into thirds. The other options 

split the area into three viewports: one large viewport and two smaller ones. The Above, 

Below, Left, and Right options specify where the larger viewport is placed.  

Specify first corner or [Fit] <Fit>: Specify a point or press ENTER 

                               
First Corner  

Position and size new viewports using the window selection method; the viewports are 

fit into the selected area. 

Fit  

Size the viewports to fill the drawing area. 

4 
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Divide the specified area horizontally and vertically into four viewports of equal size. 

Specify first corner or [Fit] <Fit>: Specify a point or press ENTER 

                               
First Corner  

Position and size new viewports using the window selection method; the viewports are 

fit into the selected area. 

Fit  

Size the viewports to fill the drawing area. 

5.8. View Manager 
Create, set, rename, modify, and deletes named views, and switch quickly between 

each views, It is helpful to reduce many unnecessary view adjust operation 

Command: View 

Menu: View> Named Views 

 
There are two tabs in this dialog box, named view tab and orthographic isometric 

view tab. 

1) Named Views Tab 
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Set Current: Restore the selected view. 

New: Create a named view. And “new view” dialog box will emerge 

Details: Display “detail of view” dialog box 

2) Orthographic Isometric View Tab 

 
Set Current: Restore the selected view. 

Current View: Display the name of current view 

Relative to: Specify the base coordinate system which is used to define the 

orthographic view, the WCS is the default base coordinate system. 

Recover Orthographic UCS and View: Restore the relative UCS when set 

orthographic view as current 

 

5.9. Render 
(GstarCAD LT, Regular and Premium Standard version don’t include the following 

functions) 

3D rendering functions, including light source, material, the application of 

background and render settings; Render Window supports the rotation、zoom、observe 

the rendering effect dynamically of rendering model. 
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Rendering creates a 2D image based on your 3D scene. It shades the scene's 

geometry using the lighting you've set up, the materials you've applied, and 

environmental settings such as background and fog. 

5.9.1. Render 
Pull-down menu: View> render > render.  

Toolbar:  

Command: render 

At a basic level, you can use the render command to render your model without 

applying any materials, adding any lights, or setting up a scene. When you render a new 

model, the renderer automatically uses a virtual “over-the-shoulder” distant light. You 

cannot move or adjust this light. 

 

 
 

5.9.2. Light 

Lighting adds the finishing touch to the scene.You can add point lights, spotlights, and 

distant lights and set the location and photometric properties of each. 
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 Point Light 

Pull-down menu: View> Render > Light>New Point Light.  

Toolbar:  

Command: pointlight 

A point light radiates light in all directions from its location. A point light does not 
target an object. Use point lights for general lighting effects. 

 Spotlights 

Pull-down menu: View> Render > Light>New Spotlights.  

Command: Spotlight 

A spotlight can be directed towards an object. 

 Distant Lights 

Pull-down menu: View> Render > Light>New Distant Lights 

Command: distantlight 

The sun is a light that simulates the effect of sunlight and can be used to show how the 

shadows cast by a structure affect the surrounding area. 

 Light List 

Pull-down menu: View> Render > Light>Light List 

Toolbar:  

Command: distantlight 
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5.9.3. Materials 

You can add materials to objects in your drawings to provide a realistic effect. 

In the context of rendering, materials describe how an object reflects or transmits light. Within a 

material, maps can simulate textures, bump effects, reflections, or refractions. 

Pull-down menu: View> Render > Material 

Toolbar:  

Command: material 

 

 

 
 
5.9.4. Render Environment  

You can use environmental features to set up atmospheric effects or background 



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 94

images 

You can enhance a rendered image by means of atmospheric effects like fog and 

depth cueing or by adding a bitmap image as a background. 

Pull-down menu: View> Render > Render Environment 

Toolbar:  

Command: RendEnv 

 
 

Fog and depth cueing are actually two extremes of the same effect: a white color is fog, 

and a black color is traditional depth cueing. You can use any color in between. 

5.9.5. Advanced Render Settings 
Pull-down menu: View> Render > Advanced Render Settings 

Toolbar:  

Command: AdvanceRenderSettings 
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5.9.6. Render Window 

The Render Window displays rendered output of the current model 

 
 
 
 

 

 

 



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 96

Chapter 6 Dimensions 
Dimensioning is the process of adding measurement annotation to a drawing. 

You can create dimensions for a variety of object types in many orientations. The basic 

types of dimensioning are: 

Linear  

Radial (radius and diameter)  

Angular  

Ordinate  

Arc Length  

The correct use of dimension tools is the key to produce clear and concise measured 

drawings.  

If you just need to quickly find a description of the various dimension commands, click 

the appropriate button on the Quick Find toolbar below. 

 
You can also use dimension commands in the pull-down menu.  

 

6.1. Dimension Style 
Dimension styles are the main method used to control the appearance of dimensions. 

Using styles you can change the text font, the arrow head style, the relative position of 

the text, the scale of dimensions and many other parameters. 

Pull-down menu: Format>Dimension style or dimension>Dimension style 

Commands: DDIM or DIMSTYLE 
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The Dimension Style command can be used to change the appearance of dimensions. 

The best method is to create a new style before you start creating dimensions so that 

you can leave the STANDARD style as a default option. 

Creating a new style 

To create a new dimension style, make sure the STANDARD style is the current style. 

Click the “New” button. The new style is automatically set as the current style. Simply 

input a new style name in the “Create New Dimension Style” dialog box. 

 
Click the “Continue” button, you can see the “Make the Dimension Style” dialogue box, 

you can set the color, lineweight, extend beyond ticks and baseline spacing of 

dimension lines and extension lines. 
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Setting the Arrowhead 

You can select the new arrow type in the dialogue box. If you require different 

arrowheads at each end of your dimensions you can set the other type using the "2nd" 

drop-down list. You can also set the arrow size and center marks for circles. 

Setting Text Style 

You can select the new text in the dialogue box. You can set the text style, text color, 

text height and fraction height scale of text appearance. You can also set the text 

placement and text alignment. 

Setting Dimension Style and Fit 

When you are working with drawings which will be plotted at different scales, you will 

need some way of changing the scale of the dimension lines relative to your drawing so 

that they always display the same size, irrespective of plotting scale. You can achieve 

this by using the Scale variable. The scaling applies to individual styles, so you could 

create different styles with different dimension scales to be used for different plotting 

scales. 

When there isn’t enough room to place arrows inside extension lines, you can select the 

way to move outside the extension. Also when text is not in the default position, you 

can select the way to place it. 

Setting Main Unit 

You can select the unit format, precision of linear dimensions and angular dimensions in 

the dialogue box.  

You may have a drawing where different units are being used for different elements of 

the drawing. In such a case it is a good idea to include units to avoid confusion. 

Remember that the main idea behind dimensioning is to give the maximum amount of 

information in the clearest and most concise way.  

6.2. Linear 
Input horizontal or vertical dimensions. 

Pull-down menu: Dimensions>Linear 

Toolbar:  

Commands: DIMLINEAR or DIMLIN  
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Specify first extension line origin or <select object>: (pick first point of a line) 

Specify second extension line origin: (pick second point of a line) 

Specify dimension line location or 

[Mtext/Text/Angle/Horizontal/Vertical/Rotated]:(pick location of dimension line) 

 
Command: _dimlinear 

Specify first extension line origin or <select object>: (pick P1) 

Specify second extension line origin: (pick P2) 

Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: 

(pick P3) 

Dimension text = 5 

Command: _dimlinear 

Specify first extension line origin or <select object>: (pick P1) 

Specify second extension line origin: (pick P4) 

Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: 

(pick P5) 

Dimension text = 3 
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6.3. Aligned 
Input dimensions parallel with sloped region. 

Pull-down menu: Dimensions> Aligned 

Toolbar:  

Commands: DIMALIGNED or DIMALI or DAL  

 
Specify first extension line origin or <select object>: (pick first point of a line) 

Specify second extension line origin: (point second point of a line) 

Specify dimension line location or [Mtext/Text/Angle]: (pick location of dimension 

line) 

The usage of aligned 

 
Command: _dimaligned 

Specify first extension line origin or <select object>: (pick P1) 

Specify second extension line origin: (point P2) 

Specify dimension line location or [Mtext/Text/Angle]: (pick P5) 

Dimension text = 2.7 
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Command: _dimaligned  

Specify first extension line origin or <select object>: (pick P2) 

Specify second extension line origin: (point P3) 

Specify dimension line location or [Mtext/Text/Angle]: (pick P4) 

Dimension text = 3.5 

Command: _dimaligned 

Specify first extension line origin or <select object>: (pick P1) 

Specify second extension line origin: (point P3) 

Specify dimension line location or [Mtext/Text/Angle]: (pick P6) 

Dimension text = 5.0 

6.4. Ordinate 
DIMORDINATE is used to make dimensions of relative distance between the origin 

and entities. 

Pull-down menu: Dimensions> Ordinate 

Toolbar:  

Commands: DIMORDINATE or DIMORD 

 
Specify feature location: (pick dimension point) 

Specify leader endpoint or [Xdatum/Ydatum/Mtext/Text/Angle]: (pick location of 

dimension) 

The usage of ordinate 
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Command: _dimordinate 

Specify feature location: (pick P1) 

Specify leader endpoint or [Xdatum/Ydatum/Mtext/Text/Angle]: (pick P4) 

Dimension text = 0 

Command: _dimordinate 

Specify feature location: (pick P3) 

Specify leader endpoint or [Xdatum/Ydatum/Mtext/Text/Angle]: (pick P5) 

Dimension text = 5 

Command: _dimordinate 

Specify feature location: (pick P2) 

Specify leader endpoint or [Xdatum/Ydatum/Mtext/Text/Angle]: (pick P6) 

Dimension text = 4 

6.5. Radius 
Input the radius of circles or arcs. 

Pull-down menu: Dimensions>Radius 

Toolbar:  

Commands: DIMRADIUS or DIMRAD   
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Select arc or circle: (select circles or arcs to input dimension) 

Specify dimension line location or [Mtext/Text/Angle]: (pick location of dimension) 

The usage of radius  

 
Command: _dimradius  

Select arc or circle: (select S1) 

Specify dimension line location or [Mtext/Text/Angle]: (pick P1) 

Dimension text = 2 

Command: _dimradius 

Select arc or circle: (select S2) 

Specify dimension line location or [Mtext/Text/Angle]: (pick P2) 

Dimension text = 4 

6.6. Diameter 
Input the diameter of circles or arcs. 

Pull-down menu: Dimensions>Diameter 

Toolbar:  

Commands: DIMDIAMETER or DIMDIA   
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Select arc or circle: (select circles or arcs to input dimension) 

Specify dimension line location or [Mtext/Text/Angle]: (pick location of dimension) 

The usage of arc 

 

 
Command: _dimradius  

Select arc or circle: (select S1) 

Specify dimension line location or [Mtext/Text/Angle]: (pick P1) 

Dimension text =4 

Command: _dimradius   

Select arc or circle: (select S2) 

Specify dimension line location or [Mtext/Text/Angle]: (pick P2) 

Dimension text =8 

6.7. Angular 
Input the angular of arc, circle or line. 

Pull-down menu: Dimensions>Angle 

Toolbar:  

Commands: DIMANGULAR  
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Select arc, circle, line, or <specify vertex>: (select arc, circle, line to input dimension) 

Specify angle vertex: 

The usage of angle 

 
Command: _dimangular 

Select arc, circle, line, or <specify vertex>: (pick L1) 

Select second line: (pick L2) 

Specify dimension arc line location or [Mtext/Text/Angle]: (pick P1) 

Dimension text = 42 

Command: _dimangular  

Select arc, circle, line, or <specify vertex>: (pick P2) 

Specify second angle endpoint: (pick P3) 

Specify dimension arc line location or [Mtext/Text/Angle]: (pick P4) 

Dimension text = 283 

Command: _dimangular 

Select arc, circle, line, or <specify vertex>: (pick S3) 

Specify dimension arc line location or [Mtext/Text/Angle]: (pick P5) 

Dimension text = 137 
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6.8. Baseline 
BASELINE dimension is used to make dimensions base on one referenced line in order 

to understand the distances easily as following. 

Pull-down menu: Dimensions>Baseline 

Toolbar:  

Commands: DIMBASELINE or DIMBASE 

 

 
Specify a second extension line origin or [Select] <Select>: (pick second point) 

Select base dimension: 

The usage of baseline 

First of all, after you input a horizontal dimension, input BASELINE dimensions. 

 
Command: _dimbaseline 

Specify first extension line origin or <select object>: (pick P1) 
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Specify second extension line origin: (pick P2) 

Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: 

(pick P3) 

Command: _dimbaseline 

Specify a second extension line origin or [Select] <Select>: (pick P4) 

Dimension text = 60 

Specify a second extension line origin or [Select] <Select>: (pick P5) 

Dimension text = 80 

6.9. Continue 
DIMCONTINUE is used to make dimensions continuously as following. 

Pull-down menu: Dimensions>Continue 

Toolbar:  

Commands: DIMCONTINUE or DIMCONT  

 
The usage of continue 

First of all, after you input a reference dimension, input continuous dimensions. 
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Command: _dimcontinue 

Specify first extension line origin or <select object>: (pick P1) 

Specify second extension line origin: (pick P2) 

Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: 

(pick P3) 

Command: _dimcontinue 

Specify a second extension line origin or [Select] <Select>: (pick P4) 

Dimension text = 40 

Specify a second extension line origin or [Select] <Select>: (pick P5) 

Dimension text = 20 

Specify a second extension line origin or [Select] <Select>: 

6.10. Leader 
A leader object is a line or a spline with an arrowhead at one end and a multiline text 

object or block at the other. In some cases, a short horizontal line, called a landing, 

connects text or blocks and feature control frames to the leader line. 

Pull-down menu: Dimensions>Leader 

Toolbar:  

Commands: DIMLEADER or LEADER  
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Specify first leader point: (pick start point) 

Specify next point: (pick next point) 

Specify next point, or [Annotation(A)/Format(F)/Undo(U)] <Annotation>:(pick next 

point) 

Enter first line of annotation text, or <Setting>: (input dimension text) 

The usage of leader 

 
Command: _leader 

Specify first leader point, or [Settings] <Settings>: (pick P1) 

Length/<Next point>: (pick P2) 

Length/<Next point>: (pick P3) 

Specify the text width <2.000000>: 

Enter first line of annotation text <Mtext>:%%C100 

6.11. Tolerance 
Geometric tolerances show acceptable deviations of form, profile, orientation, location, 

and runout of a feature. You add geometric tolerances in feature control frames. These 

frames contain all the tolerance information for a single dimension. Geometric 

tolerances can be created with or without leader lines, depending on whether you create 
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them with TOLERANCE or LEADER.  

A feature control frame consists of two or more components. The first feature control 

frame contains a symbol that represents the geometric characteristic to which a 

tolerance is being applied, for example, location, profile, form, orientation, or runout. 

Form tolerances control straightness, flatness, circularity and cylindricity; profiles 

control line and surface. In the illustration, the characteristic is position.  

 

 
Pull-down menu: Dimensions>Tolerance 

Toolbar:  

Command: TOLERANCE   

 
To create a tolerance dimension 

1. Command: TOLERANCE 

2. Click the Tolerance tab.  

3. Select the Append Dimension Tolerances check box.  

4. Type or select the lower tolerance limit.  

5. Type or select the upper tolerance limit.  
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6. Click OK.  

7. Insert the dimension.  

 

6.12. Center Mark 
DIMCENTER is used to make dimensions of circles or arcs. If “DIMCENTER” is a 

negative (-) value, center line is drawn. If it is a positive (+) value, center mark is 

drawn. 

Pull-down menu: Dimensions>Center Mark 

Commands: DIMCENTER or DCE   

Toolbar:  

 
Select arc or circle: (select circles or arcs) 

The usage of center mark 
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Command: DIMCEN   

New current value for DIMCEN<0.0100>: 1 

Command: _DIMCENTER 

Select arc or circle: (select S1) 

Command: DIMCEN   

New current value for DIMCEN<1.0000>: -1 

Command: _DIMCENTER 

Select arc or circle: (select S2). 

6.13. Making Dimensions Oblique 
You can create dimensions with extension lines that are not perpendicular to their 

dimension lines. Extension lines are created perpendicular to the dimension line. 

However, if the extension lines conflict with other objects in a drawing, you can change 

their angle after the dimension has been drawn. New dimensions are not affected when 

you make an existing dimension oblique. 

Pull-down menu: Dimensions>Olique 

Command: DIMEDIT then choose Oblique 

 
The example of dimension oblique 
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6.14. Editing Dimension Text 
You can rotate the text of an existing dimension, move the dimension text to a new 

position, or replace selected dimension text with new text. You can also restore 

dimension text to its original position as defined by the current dimension style. 

When you rotate or replace selected text, you specify the change first, and then select 

one or more dimensions to apply the change. All the selected dimensions are updated 

simultaneously. 

Pull-down menu: Dimensions>Align Text 

Command: DIMEDIT  

 
Return dimension text to its home position  

Click Dimension menu >Align Text>Home.  

Select the dimension text you want to return to its home position.  

Rotate dimension text  

Click Dimension menu >Align Text>Angle.  

Select the dimension to edit.  
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Enter the new angle for the text.  

Move text to the left side of the dimension line  

Click Dimension menu>Align Text>Left.  

Select the dimension.  

The dimension text is left-justified along the dimension line inside the extension lines. 

You can choose the Center or Right options to move the text to the center or right of the 

dimension line.  

Move text to the center of the dimension line  

Click Dimension menu>Align Text >Center  

Select the dimension.  

The dimension text is center-justified along the dimension line inside the extension lines. 

You can choose the right or Left options to move the text to the right or left of the 

dimension line.  

Move text to the right side of the dimension line  

Click Dimension menu>Align Text>Right 

Select the dimension.  

The dimension text is right-justified along the dimension line inside the extension lines. 

You can choose the Center or Left options to move the text to the center or left of the 

dimension line.  

6.15. Override 
With dimension style overrides, you can temporarily change a dimensioning system 

variable without changing the current dimension style. 

A dimension style override is a change made to specific settings in the current 

dimension style. It is equivalent to changing a dimensioning system variable without 

changing the current dimension style. 

 

Pull-down menu: Dimension>Override 

Command: DIMOVERRIDE 
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Set up dimension style overrides  

Click Dimension menu>Dimension style.  

In the Dimension Style Manager, under Styles, select the dimension style for which you 

want to create an override. Click Override.  

In the Override Current Style dialog box, make changes to the dimension style by 

clicking the appropriate tab.  

Click OK to return to the Dimension Style Manager.  

The dimension style overrides are listed below the style they modify in the dimension 

style name list.  

Click Close.  

To apply dimension style overrides  

Click Dimension menu>Dimension style.  

In the Dimension Style Manager, click Override.  

In the Override Current Style dialog box, enter the style overrides. Click OK.  

The program displays <style overrides> below the dimension style name in the 

Dimension Style Manager dialog box. After you create dimension style overrides, you 

can continue to modify dimension styles, compare them with other dimension styles, or 

delete or rename the overrides. 

 

6.16. Associative Dimensions 

Dimensions can be associative, nonassociative, or exploded. Associative 

dimensions adjust to changes in the geometric objects that they measure. 
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Dimension associativity defines the relationship between geometric objects and the 

dimensions that give their distance and angles. There are three types of associativity 

between geometric objects and dimensions. 

 Associative dimensions. Automatically adjust their locations, orientations, and 

measurement values when the geometric objects associated with them are modified. 

Dimensions in a layout may be associated to objects in model space. The 

DIMASSOC system variable is set to 2. 

 Nonassociative dimensions. Selected and modified with the geometry they 

measure. Nonassociative dimensions do not change when the geometric objects 

they measure are modified. The dimension variable DIMASSOC is set to 1. 

 Exploded dimensions. Contain a collection of separate objects rather than a single 

dimension object. The DIMASSOC system variable is set to 0. 
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Chapter 7 Text 
7.1. Text Style 
STYLE command is used to set up text font, scale and angle ratio of the text. 

Pull-down menu: Format>Text Style 

Command : STYLE   

 
 Select text font when dialogue box is displayed. 

 
 Change text height, width factor and oblique angle. Width factor is a ratio of 

width-length of the text. 

 
 After selecting text font then click “apply” 

7.2. Single Line Text 
DTEXT is used to input the text in order to mark the title and part table in the drawing. 
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(1) Execution 

Pull-down menu: Draw>Text>Single Line Text 

Command: DTEXT or TEXT  

 
Text: Style/Align/Fit/Center/Middle/Right/Justify/<Start point>:(pick start point) 

Height of text <3.0000>: (input text height) 

Rotation angle of text <0>: (input text slope) 

Text: (input text) 

(2) Usage 

 Input text 

 
Command: _dtext  

Text Style/Align/Fit/Center/Middle/Right/Justify/< Start point>: (pick P1) 

Height of text<3.0000>:3  

Rotation angle of text<0>:   

Text: GstarCAD  

Text:   

 Change the height and slope of the text 
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Command: _dtext 

Text Style/Align/Fit/Center/Middle/Right/Justify/< Start point>: (pick P1) 

Height of text<3.0000>:6 

Rotation angle of text<0>: 60  

Text: GstarCAD 

 Use special text 

 
Command: _dtext 

Text Style/Align/Fit/Center/Middle/Right/Justify/< Start point: (pick P1) 

Height of text<6.0000>: 3  

Rotation angle of text<0>:   

Text: %%C100   (mark diameter) 

Text: 60%%D   (mark angle) 

Text: %%P5  (mark tolerance) 

Text: %%U GstarCAD    (draw underline) 

Text: %%O GstarCAD Software   (draw upperline) 

Text: 
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7.3. Multiline Text 
You can create a multiline text (mtext) object by entering or importing text.  

To create multiline text 

Pull-down menu: Draw>Text>Multiline Text 

Toolbar:  

Commands: MTEXT or MT 

Multiline Text:   

Specify first corner: pick upper-left point of text input area 

Specify the opposit corner or [Height/Justification/Linespacing/Rotation/Style/Width]： 

 
 

Enter text. 

 

Within the multiline text object, you can override the current text style by applying 

formatting such as underlining, boldface, and different fonts to individual characters. 

You can also create stacked text, such as fractions or geometric tolerances and insert 

special characters, including Unicode characters, for TrueType fonts.  
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7.4. Ddedit 
DDEDIT is used to modify colors, layers, size, font and angle of the text by selecting 

texts that are already inputted. 

(1) Execution 

Commands: DDEDIT or ENTPROP   

Select entities to modify: (select text to modify) 

(2) Usage 

 Modify the text. 

Command: Ddedit 

Select entities to modify 

 
 Modify selected texts. 
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Chapter 8 Drawing Aids 

8.1. Ortho Mode 
Status Bar:  

Pull-down menu: None  

Command: ORTHO or F8  

Ortho is short for orthogonal, which means either vertical or horizontal. Like the other 

options on the status bar, Ortho is not really a command, it is a drawing mode which can 

either be turned on or off. Ortho mode can be toggled on or off in one of three ways. 

The quickest way is just to click on the ORTHO button on the status bar.  

Ortho can also be toggled on and off using the F8 Function key .Finally, you can also 

type ORTHO at the command line. 

Command Sequence 

Command: ORTHO 

Enter mode [ON/OFF] <OFF>: (type ON or OFF) 

8.2. The Drawing Grid 
Status Bar:    

Pull-down menu: None  

Command: GRID or F7  

The drawing grid is a regular pattern of dots displayed on the screen which acts as a 

visual aid, it is the equivalent of having a sheet of graph paper behind your drawing on a 

drawing board. You can control the grid spacing, so it can give you a general idea about 

the size of drawn objects. It can also be used to define the extent of your drawing.  

Command Sequence 

Command: GRID 

Specify grid spacing(X) or [ON/OFF/Snap/Aspect] <10.000>: (enter grid spacing) 

 
Grid spacing set to 10 drawing units  
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Grid spacing set to 5 drawing units  

Although you can use the command line to control the visibility of the grid by using the 

"ON" and "OFF" options this is more easily achieved using the F7 key or, better still, by 

clicking the GRID button on the status bar. However, the command line does offer some 

additional options. The Snap option allows you to automatically set the grid spacing to 

the current snap spacing. You can also change the aspect ration of the grid. By default, 

the X and Y spacing of the Grid are the same, resulting in a regular square matrix of 

grid points. But you can display a grid with different X and Y spacing by using the 

"Aspect" option. 

Grid mode and X/Y spacing can also be set using the Drafting Settings dialogue box. 

You can access grid settings by right-clicking the Grid button on the status bar and 

selecting “Snap and Grid” from the menu.  

You may have noticed that the grid does not extend infinitely in all directions. In fact, it 

is only displayed within a finite rectangle. You can control the extent of the visible grid 

using Drawing Limits. 

8.3. Snap Mode 
Status Bar:   

Pull-down menu: None  

Command: SNAP or F9  

With Snap mode turned on GstarCAD only allows you to pick points which lie on a 

regular grid. The Snap grid is completely independent of the display grid. However, the 

Grid spacing and Snap spacing are usually set to the same value to avoid confusion. You 

can force the display grid to conform with the snap grid by setting the display grid 

spacing to zero. The display grid will automatically change each time when the snap 

grid is changed. When Snap mode is turned on and the Grid is displayed, the Snap and 

Grid spacings are the same and the crosshairs will jump from one grid point to another 

as you move across the screen. This makes it very easy to draw objects which have a 
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regular shape. The Snap command is used to set the snap spacing and to toggle Snap 

mode. 

Command Sequence 

Command: SNAP 

Snap is on, x and y = 5.0000:  [OFF/Rotate/Style/Aspect] <Snap spacing>: 

The "Aspect" option can be used to vary the horizontal and vertical snap spacings 

independently. 

"Rotate" is used to set the snap grid to any angle. 

You can also set the snap style to either Isometric or Standard (the default) using the 

"Style" option. The Standard style is used for almost all drawing situations including 

detail drawings in Orthographic Projection. The Isometric style is specifically to aid the 

creation of drawings in Isometric Projection (see the illustrations on the right). 

The grid snap is particularly useful if you need lots of modular objects such as bricks or 

paviors. In the illustration on the below, the Aspect option is used to set the X and Y 

snap spacings to the brick dimensions and the Rotate option is used to set the orientation 

of the bond. Once these settings are made, the bricks can be accurately drawn without 

any other drawing aids. 

 
All of the Snap variables can also be set using the Drafting Settings dialogue box. 

Right-click on the SNAP button and choose “Snap and Grid” from the menu. 

8.4. Object Snaps 
The main reason for using the Object Snaps is that they are used very frequently. 

Experienced users will use Object Snaps all of the time, because they are the only way 

to make sure that the objects you are drawing are drawn accurately.  

Object Snap Toolbar:  

 
1. Endpoint 
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Toolbar: Object Snap   

The Endpoint Osnap snaps to the end points of lines and arcs and to polyline vertices. 

This is one of the most useful and commonly used Osnaps. 

 
2. Midpoint 

 Toolbar: Object Snap   

The Midpoint Osnap snaps to the mid points of lines and arcs and to the mid point of 

polyline segments. 

 
3. Intersection 

Toolbar: Object Snap   

The Intersection Osnap snaps to the physical intersection of any two drawing objects 

(i.e. where lines, arcs or circles etc. cross each other) and to Polyline vertices.  

 
4. Apparent Intersect 

 Toolbar: Object Snap   

Apparent Intersection snaps to the point where objects appear to intersect in the current 

view. For example, you may be looking at a drawing in plan view where two lines cross, 

as in the illustration. However, since GstarCAD is a 3 dimensional drawing 

environment, the two lines may not physically intersect. One line may be at ground 
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level and the other may be 10 meters or more above or below ground level. As with the 

Intersection Osnap, Apparent Intersection also has an "Extended" mode. 

 
5. Extension 

Toolbar: Object Snap   

The Extension Osnap enables you to snap to some point along the imaginary extension 

of a line, arc or polyline segment. To use this osnap, you must hover the cursor over the 

end of the line you want to extend. When the line end is found, a small cross appears at 

the endpoint and a dashed extension line is displayed from the endpoint to the cursor, 

providing the cursor remains close to the extension. The Snap Tip for Extension also 

includes the relative polar co-ordinate of the current cursor position. This can be a 

useful guide for positioning your next pick point. The co-ordinate includes a distance 

from the endpoint and the angle of the extension. In the case of the arc extension, the 

Snap Tip displays the distance along the arc.  

   
6. Center 

    Toolbar: Object Snap   

The Center Osnap snaps to the center of a circle, arc or polyline arc segment. The cursor 

must pass over the circumference of the circle or the arc so that the center can be found 

 
7. Quadrant 
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Toolbar: Object Snap   

The Quadrant Osnap snaps to one of the four circle quadrant points located at north, 

south, east and west or 90, 270, 0 and 180 degrees respectively. 

 
8. Tangent 

Toolbar: Object Snap   

The Tangent Osnap snaps to a tangent point on a circle. This osnap works in two ways. 

You can either draw a line from a point to the tangent point (see illustration) or you can 

draw a line from a tangent point, the latter is referred to as the "Deferred Tangent" snap 

mode. 

 
9. Perpendicular 

Toolbar: Object Snap   

The Perpendicular Osnap snaps to a point which forms a perpendicular with the selected 

object. As with the Tangent Osnap, Perpendicular can be used to draw a line to a 

perpendicular point, as in the illustration or from a perpendicular point, known as the 

"Deferred Perpendicular" snap mode. 

 
10. Parallel 

Toolbar: Object Snap   



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 128

 The Parallel Osnap is used to draw a line parallel to any other line in your drawing. In 

operation, this osnap is slightly less intuitive than some of the others. To draw a parallel 

line, first start the Line command, specify the first point when prompted and then start 

the Parallel Osnap. Hover the cursor over an existing line until you see the Parallel snap 

marker. Now, move the cursor close to a parallel position and a dotted line will appear, 

indicating the parallel. You can now pick the second point of your line.  

 
11. Insert 

Toolbar: Object Snap   

The Insert Osnap snaps to the insertion point of a block, text or an image. 

 
12. Node 

Toolbar: Object Snap   

 
The Node Osnap snaps to the center of a Point object. This osnap can be useful if you 

have created a number of Points with the Measure or Divide commands. You could, for 

example insert a number of regularly spaced tree symbols (blocks) along a line by using 

the Node Osnap for the insertion point of each block. 
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The image as a Spline (cyan). The Measure command has been used to set Points (red) 

at regular intervals and a tree symbol has been inserted with the Insert command at each 

Point location using the Node Osnap. 

13. Nearest 

Toolbar: Object Snap   

The Nearest Osnap snaps to the nearest point on a drawing object. This Osnap is useful 

if you want to make sure that a pick point lies on a drawing object but you don't 

necessarily mind exactly where it is located. 

 

8.5. Polar Tracking 
Polar Tracking is a bit like Ortho mode on steroids. Whereas Ortho constrains your lines 

to either the horizontal or the vertical, Polar Tracking allows you to snap into whatever 

angles you choose to configure. 

 
By default, Polar Tracking snaps only to the horizontal and the vertical. When you are 

drawing a line, pick the first point and then move the cursor close to a vertical or 

horizontal location and your cursor will snap into place. You will see a polar tracking 

vector and a tool tip which displays the angle and the distance from the pick point; in 

other words, a relative polar co-ordinate. 
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In this default setting, Polar Tracking works like a more flexible version of Ortho but if 

you look at the Polar Tracking tab on the Drafting Settings dialogue box, you will see 

just how versatile it can be. Right-click on the POLAR button on the status bar and 

choose “Polar Tracking” from the menu. 

 
 You can use the Increment angle drop-down list to select one of the preset angle 

increments. For example, if the increment angle is set to 22.5 degrees, Polar Tracking 

will snap at 22.5 degree increments starting with zero degrees. 

 
Incidentally, you will notice that the reported angle on the tool tip shown in the 

illustration on the right is "23", whereas the actual snap angle is 22.5 degrees. This is 

because angular units are set to display only whole degrees and so, 22.5 is rounded up 

to 23.  

You may sometimes need to snap to specific angles. Say you are working on a drawing 

of a site and the buildings are orientated in a particular way. If you know the angle, you 

can use the Additional angles option to add this specific angle so that Polar Tracking 

will snap to it. 

To set additional angles, all you need to do is click on the New button and enter the 

value in the list. The Delete button can be used to remove unwanted angles. It is also 

possible to temporarily suspend Additional angles. You can do this by deselecting the 



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 131

Additional angles check box. When you do this, the angles list is greyed out and those 

angles won't be used for Polar Tracking until you check the box again. 

One of the great benefits of Polar Tracking is that, when used in combination with direct 

distance entry, you can draw lines of a given length and at a preset angle without using 

any construction lines and without the need for entering relative co-ordinates. Drawing 

using this technique can be extremely efficient 
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Chapter 9 Entity Attributes 
Every object, such as a line or a circle has properties. Some properties such as Color, 

Linetype and Layer are common to all objects. Some objects have properties which are 

specific to themselves.   

9.1. Layers 
The layer is very important and the correct use of layers can make your drawing much 

easier to work with. Layers are very powerful because you can have many layers in a 

single drawing and you can control the visibility, color and linetype of layers 

independently. This makes you become efficiently to work with complicated drawings 

Layers are a effective way to order your drawing.  

9.1.1. Creating a New Layer 
Pull-down: format>Layer 

Toolbar   

Command: LAYER  

 
Click on the "New" button. A new layer called "Layer1" is automatically created in the 

layer list below layer 0. As you can see from the illustration, the layer name is 

automatically highlighted for you so that you can give the layer a more meaningful 

name. When you have entered an appropriate name, press the OK to complete the 

operation. You have now created a new layer and given it a name. Notice that by default 

it has been assigned the color white and the linetype "Continuous". 
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9.1.2. Set the Color of a Layer 
To set a layer color, you can click on the color icon in the layer properties manager with 

the layer you want to set color 

 
Notice that all layers have their own color icon. Click on the icon and then you will 

open the Select Color dialogue box. You can select any of the 255 standard colors by 

picking on the color palette or by entering the color name or number in the text edit box. 

When you have selected the color you want, click on the "OK" button to set the color.  
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Assigning different colors to your layers will make your work much easier.  

9.1.3. Set and Load the Linetype of a Layer 
In the same way that you can assign a color to a layer you can also assign a linetype to a 

layer. To set a linetype to a layer, in the layer properties manager, click on the current 

linetype name associated with your layer in the layer list. By default, layers have the 

"Continuous" linetype. Click on the linetype name and you will open the Select 

Linetype dialogue box. You will notice that the "Continuous" linetype is the only one 

listed. That's because all linetypes, except "Continuous", are stored in an external file 

and have to be loaded before they can be used. 

 

 
To load a linetype, click on the "Load..." button in the “Select Linetype” dialogue box. 

The Load or Reload Linetypes dialogue box appears and displays a list of the available 

linetypes. Select as many of the listed linetypes as you wish and then click the OK 

button to return to the Select Linetype dialogue box. 
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When you return to the Select Linetype dialogue box the loaded linetypes are displayed 

in the list.  

9.1.4. Control Layer States 
There are a number of other properties all of which relate to whether or not objects on a 

layer can be seen and/or modified. The current states of these properties are all indicated 

by icons in the various layer lists. The meaning of these icons is shown in the table 

below: 

 

ICON NAME DESCRIPTION 

 On The layer is visible unless it is also frozen 

 Off The layer is invisible but objects are still 
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regenerated unless it is also frozen  

 Thaw in all viewports The layer is not frozen 

 Freeze in all viewports The layer is invisible and objects are suspended 

from regeneration 

 Unlock The layer is unlocked 

 Lock The layer is locked and objects cannot be selected 

or modified 

9.2. LINETYPE 
A linetype is a repeating pattern of dashes, dots, and blank spaces displayed in a line or 

a curve. You assign linetypes to objects either by layer or by specifying the linetype 

explicitly, independent of layers. In addition to choosing a linetype, you can set its scale 

to control the size of the dashes and spaces, and you can create your own custom 

linetypes.  

9.2.1. The Linetype Command 
Pull-down menu: Format>Linetype 

Commands: LINETYPE or LT   

 
If you have just started a new drawing the only true linetype available will be the 

"Continuous" linetype. Before you are able to assign any other linetype, you must first 

load the linetypes you may need. To load linetypes you must use the "Linetype" 

command. See illustration below:  
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In the “linetype manager” dialogue box, click on the "Load" button, this brings up the 

Load or Reload Linetypes dialogue box .Select the required linetypes from this dialogue 

box and then click the "OK" button to return to the “linetype manager” dialogue box, 

where you will see the newly loaded linetypes in the Linetype list.  

 

 
9.2.2. Set the Linetype Scale 
In many cases your linetypes will display just as you want them. However, it is 

inevitable that at some time you will need to change the scale at which your linetypes 

are displayed. By default the linetype scale is set to 1.0, this means that each linetype 

pattern will repeat every 1.0 drawing units. To make the pattern appear larger, change 

the scale to a larger number. Setting the linetype scale to 5.0 for example causes the 

linetype pattern to repeat every 5.0 drawing units so that the pattern will appear 5 times 

larger. Conversely, setting the scale to 0.2 causes a repetition every 0.2 drawing units 

which will make the pattern appear 5 times smaller.  
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To change the linetype scale, you can set the linetype scale by changing the value in the 

"Global scale factor" edit box or “current object scale” edit box. Once you have 

changed the scale factor, click on the OK button to return to your drawing. GstarCAD 

automatically regenerates the drawing to display all linetypes with the new scale factor. 

 
Linetype scale = 1.0  

 
Linetype scale = 2. 

 

Linetype scale = 0.5  

 



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 139

Chapter 10 Blocks and External reference 

 
Blocks, attributes, and external references provide mechanisms for managing 

entities in your drawings and for including additional information with the standard 

drawing entities.  

With blocks, you can combine numerous entities into a single entity, and then reuse 

it, inserting multiple copies. 

With attributes, you can associate text, such as part numbers or prices, with blocks, 

and then extract the text-attribute information to a separate file, such as a database, for 

further analysis.  

With external references, you can link separate reference drawing files to the 

current drawing to combine information without adding the contents of the reference 

drawings to a drawing. If you make changes to the referenced file, all references are 

updated automatically. 

10.1. Working with Blocks 
10.1.1. Creating Blocks 
Pull-down menu: Draw >Block> Make.  

Toolbar:   

Command: BLOCK 

 

10.1.2. Inserting Blocks 
When you insert a block, you must specify the insertion point, scale, and rotation angle. 
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The block's insertion point is the reference point specified when you created the block. 

When you insert a drawing as a block, the program takes the specified insertion point as 

the block insertion point. You can change the insertion point, however, by first opening 

the original drawing and redefining the block. 

Pull-down menu: Insert > Block.  

Toolbar:  

Command: Ddinsert 

 
In the Insert Block dialog box, click Block Name, specify the insertion point for the 

block, specify the x, y, and z scale factors and the rotation angle, or press Enter to 

accept the default values.  

 

10.1.3. Explode Blocks 
Pull-down menu: Modify > Explode.  

Toolbar:  

Command: EXPLODE 



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 141

 

10.2. Working with Attributes 
An attribute is a particular entity that you can save as part of a block definition. 

Attributes consist of text-based data. Attributes have either fixed or variable values. 

When you insert a block containing attributes, the program adds the fixed values to the 

drawing along with the block, and you are prompted to supply any variable values. 

After you insert blocks containing attributes, you can extract the attribute information to 

a separate file and then use that information in a spreadsheet or database to produce a 

parts list or bill of materials. You can also use attribute information to track the number 

of times a particular block is inserted into a drawing. 

Attributes can be visible or hidden. Hidden attributes are neither displayed nor printed, 

but the information is still stored in the drawing and written to a file when you extract it. 

10.2.1. Defining Attributes 
Pull-down menu: Draw >Block>Define attributes  

Command: Ddattdef 
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In the “Attribute definition” dialog box, 

Under “Attribute” type the tag, prompt, and value.  

Under “Insert Point”, specify the location of the attribute, or click Pick Point to select a 

point in the drawing. 

Under “Mode” select the optional attribute modes.  

Under “Text Options” specify the text characteristics.  

 

10.2.2. Editing Attributes Attached to Blocks 
You can edit the attribute values of a block that has been inserted into a drawing. 

1 Command : Ddatte  

2.  Select the block to edit.  

The Edit Block Attributes dialog box displays all the attributes attached to the block you 

select. 

3.  Edit the attribute values as necessary.  

4.  Click OK.  



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 143

 
A. Identifies the name of the block.  

B. Displays the names of all attributes attached to the block.  

C. Click to select attribute.  

D. Type the new value for the selected attribute.  

E. Click to update the attribute values and exit.  

F. Displays the value of each attribute attached to the block.  

G. Displays the prompt for each attribute attached to the block.  

10.2.3. Block Attribute Manager 
Manages the attributes for a selected block definition, preview modification 

automatically, it is convenient to modify attribute block in quantity. 

Command: Battman 

 
 

Select  

Allow you to use your pointing device to select a block from the drawing area. 

When you choose Select Block, the dialog box closes until you select a block from the 

drawing or cancel by pressing ESC. 

If you modify attributes of a block and then select a new block before you save the 

attribute changes you made, you are prompted to save the changes before selecting 
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another block. 

Block 

List all block definitions in the current drawing that have attributes. Select the 

block whose attributes you want to modify. 

Sync 

Update all instances of the selected block with the attribute properties currently 

defined. This does not affect any values assigned to attributes in each block. 

Move Up 

Move the selected attribute tag earlier in the prompt sequence. The Move Up 

button is not available when a constant attribute is selected. 

Move Down 

Move the selected attribute tag later in the prompt sequence. The Move Down 

button is not available when a constant attribute is selected. 

Edit 

Opens the “Edit Attribute” dialog box, where you can modify attribute properties. 

 
Remove 

Remove the selected attribute from the block definition. If Apply Changes to 

Existing References is selected in the Settings dialog box before you choose Remove, 

the attribute is removed from all instances of the block in the current drawing. The 

Remove button is not available for blocks with only one attribute. 

Settings 

Opens the “Block Attribute Settings” dialog box, where you can customize how 

attribute information is listed in the Block Attribute Manager. 
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Apply 

Apply the changes you made, but leave the dialog box open. 

 
10.3. Working with External References 
You can link entire drawings to the current drawing as external references. Unlike 

inserting a drawing as a block, in which you add all the entities from the separate 

drawing into the current drawing, external references attach a pointer to the external file. 

The entities in the external reference appear in the current drawing, but the entities 

themselves are not added to the drawing. Thus, attaching an external reference does not 

significantly increase the size of the current drawing file. 

10.3.1. Opening External References 
1. Pull-down menu: Insert > DWG Reference /Xref Manager.  

Command: Xattach/XREF  
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2. Select the external reference to open.  

3. Click Open. 

10.3.2. Reloading External References 
When you open or print a drawing, any external references in the drawing are updated 

automatically. If a drawing is already open and a referenced drawing is modified, you 

can update the current drawing manually to display the latest version of the referenced 

drawing.  

You may also want to reload an external reference that has been unloaded temporarily. 

To reload an external reference 

1. Pull-down menu: Insert > Xref Manager.  

 
2. Select the external reference to reload.  

3. Click Reload.  

10.3.3. Removing External References 
Removing external references from the current drawing is easy with the Xref Manager. 

You can unload an external reference, which keeps some information about the external 

reference in the current drawing for easy reloading later, or you can detach the external 

reference entirely.  

When you unload an external reference, you remove it from the current drawing. 

However, its elements, such as layers and linetypes, remain in the drawing and it is still 

listed in the Xref Manager. By detaching an external reference you remove it and all of 

its elements from the current drawing, and it is no longer listed in the Xref Manager. 

To unload an external reference 

1. Do one of the following:  

Pull-down menu: Insert > Xref Manager.  

Command: XRM  
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2. Select the external reference to unload.  

3. Click Unload.  

To detach an external reference 

1. Do one of the following:  

Pull-down menu: Insert > Xref Manager.  

Command: XRM  

 
2. Select the external reference to detach.  

3. Click Detach.  

10.3.4. Attaching External References 
Attaching a separate drawing to the current one creates an external reference. The 

external reference appears in the drawing as a block definition, but the drawing entities 

are linked rather than added to the current drawing. If you modify the linked drawing, 

the current drawing that contains the external reference is updated automatically when 

you open it, or you can reload the external reference manually so it reflects the latest 

version of the external reference.  

When you attach an external reference, its layers, linetypes, text styles, and other 

elements are not added to the current drawing. Rather, these elements are also linked 
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from the referenced file.  

To attach external references 

1. Do one of the following:  

Pull-down menu: Insert > Xref Manager.  

Command: XRM  

 
2. Click Attach.  

 
3. Specify the drawing file to attach as an external reference, and then click Open.  

4. In Reference Type, choose how you want to insert the drawing:  

 Attachment - inserts a copy of the drawing and includes any other drawings that are 

externally referenced within the referenced drawing.  

 Overlay - lays a copy of a drawing over your original drawing; it does not include 

any nested external references in the externally referenced drawing.  

5. Make any additional selections.  

6. Click OK.  

7. If you marked Specify On-Screen for any items, follow the prompts to attach the 

external reference.  

10.3.5. Binding External References to Drawings 
External references are not part of the drawing. Rather, they are links to an externally 
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referenced file. To provide a copy of a drawing containing external references to 

someone else, you must also provide all the external reference files. In addition, the 

person receiving the drawings must either re-create the same paths you used when 

linking the external references or change the paths for the external references.  

To provide a copy of a drawing that contains external references, it is often easier to 

first bind the external references to the drawing. Binding the external references makes 

them a permanent part of the drawing, which is similar to inserting a separate drawing 

as a block. 

You can bind external references that are attached directly to the current drawing; you 

cannot bind nested external references. 

To bind an existing external reference to a drawing 

1. Do one of the following:  

Pull-down menu: Insert > Xref Manager.  

Command: XRM  

2. Select the external reference to bind.  

 
3. Click Bind.  

4. Choose one of the following:  

 
The type of binds 

 Bind Binds: the external reference，and creates a unique name for each named entity, 

such as a layer or block, that is located in the external reference.  
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 Insert Binds: the external reference, but does not change the names of any named 

entities in the external reference.  

10.3.6. Clipping External References 
When you attach a drawing as an external reference, all of the referenced drawing 

displays in the current drawing. However, after you attach an external reference, you 

can define a clipping boundary that determines which portion of the referenced drawing 

is visible or hidden. 

You can edit, move, or copy clipped external references as the same way you modify 

unclipped external references. The boundary moves with the reference. If an external 

reference contains nested clipped external references, they also appear clipped in the 

drawing.  

10.3.6.1 Adding Clipping Boundaries 

When you create a clipping boundary, it affects only the display of the referenced 

drawing; it does not affect the original referenced drawing or any referenced geometry. 

The portion of the external reference within the clipping boundary is visible and the 

remainder of the external reference becomes hidden. 

To define a rectangular clipping boundary 

1. Do one of the following:  

Pull-down menu: Modify > Clips.  

Command: Xclip  

 

 
2. Select the external references to clip. If desired, you can also select blocks.  
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3. Press Enter.  

4. Press Enter to create a new clipping boundary.  

5. If prompted, press Enter to delete any existing boundaries.  

6. Choose Rectangular.  

7. Define the first corner of the clipping rectangle.  

8. Define the second corner of the clipping rectangle.  

The selected external references are clipped by the rectangle. 

10.3.6.2 Turning Clipping Boundaries On and Off 

You can turn xref clipping on or off. When a clipping boundary is turned off, the 

boundary does not display and the entire external reference is visible, provided that the 

geometry is on a layer that is on and thawed. When a clipping boundary is turned off, it 

still exists and can be turned on. However, deleting a clipping boundary is permanent. 

To turn clipping boundaries on and off 

1. Do one of the following:  

Pull-down menu: Modify > Clips.  

Command: Xclip 

2. Select the desired external references.  

3. Press Enter.  

4. To turn off clipping boundaries, choose Off. To turn on existing clipping boundaries, 

choose On.  

5. Press Enter.  

If you are turning off a clipping boundary, click the clipped portion of the external 

reference to view the previously hidden portion of the referenced drawing. 

10.3.6.3 Deleting Clipping Boundaries 

If you no longer need a clipping boundary for an external reference, you can delete it. 

To delete a clipping boundary 

1. Do one of the following:  

Pull-down menu: Modify > Clips.  

Command: Xclip 

2. Select the desired external references.  

3. Press Enter.  

4. Choose Delete, and then press Enter.  
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5. Click the clipped portion of the external reference.  

The previously hidden portion of the referenced drawing displays. 
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Chapter 11 Drawing in Three Dimensions 
(GstarCAD Regular Standard version don’t include the following functions in Chapter 

11) 

GstarCAD2010 supports the following types of three-dimensional models: 

 Wire-frame models, which consist of lines and curves that define the edges of a 

three-dimensional entity.  

 Surface models, which consist of both edges and the surfaces between those edges.  

 3D solids, which are three-dimensional ACIS entities that consist of faces and 

edges.  

11.1. Creating Ruled Surfaces 
You can create a ruled surface, which is a three-dimensional body that approximates the 

surface between two existing entities. You select the two entities that define the ruled 

surface. These entities can be arcs, circles, lines, points, or polylines. 

To create a ruled surface 

1. Advanced experience level  

2. Do one of the following:  

Pull-down menu: DRAW> MODELING> MESH> Ruled Mesh.  

Command: RULESURF  

 
3. Select the first defining entity.  

4. Select the second defining entity.  
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11.2. Creating Edge-defined Coons Surfaces 
You can create a surface called a Coons surface, a region connecting four edges. You 

select the entities that define the edges. Edge entities can be arcs, lines, or polylines. 

The four edge entities must form a closed loop and share endpoints. You can select the 

edges in any order.  

To create an edge-defined Coons surface 

1. Advanced experience level  

2. Do one of the following:  

Pull-down menu: DRAW> MODELING> MESH>Edge Mesh 

Command: EDGESURF  

 
3. Select the first edge.  

4. Select the second, third, and fourth edges.  
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11.3. Create a Revolved Mesh 
Use the REVSURF command to create a revolved mesh by rotating a profile of the 

object about an axis. REVSURF is useful for mesh forms with rotational symmetry. 

 

Pull-down menu: DRAW> MODELING> MESH> Revolved Mesh.  

Command: REVSURF 

 

 
The profile is called a path curve, which can be any combination of lines, circles, arcs, 

ellipses, elliptical arcs, polylines, or splines, closed polylines, polygons, closed splines, 

or donuts. 

11.4. Create a Tabulated Mesh 
With the TABSURF command, you can create a mesh representing a general tabulated 

surface defined by a path curve and a direction vector. The path curve can be a line, arc, 

circle, ellipse, elliptical arc, 2D polyline, 3D polyline, or spline. The direction vector 

can be a line or an open 2D or 3D polyline. TABSURF creates the mesh as a series of 

parallel polygons running along a specified path. You must have the original object and 

the direction vector already drawn, as shown in the following illustrations. 
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Pull-down menu: DRAW> MODELING> MESH> Tabulated Mesh.  

Command: TABSURF 

 

 

 

11.5. Creating Extruded Surfaces 
You can create an extruded surface, which is a three-dimensional body that 

approximates the surface generated by extruding a path curve along a direction vector. 

You select the two entities that define the path curve and direction vector. The length of 

the direction vector determines the distance the path curve is moved along the direction 

vector. The extruded entity can be an arc, circle, line, or polyline. You can choose a line 

or open polyline as the direction vector. The resulting body consists of a series of 

parallel polygonal planes running along the specified path. 

To create an extruded surface 

1. Advanced experience level  

2. Do one of the following:  

Pull-down menu: DRAW> MODELING> Extrude  

Toolbar:  

Command: EXTRUDE.  
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3. Select the entity to extrude.  

4. Select the extrusion path.  

 

11.6. Creating Revolved Surfaces 
You can create a surface of revolution, which is a three-dimensional body that 

approximates the surface generated by rotating a two-dimensional profile around an axis. 

You select the two entities that define the profile and the axis. You also specify the 

starting angle and the number of degrees to revolve the profile. 

Revolving the profile 360 degrees creates a closed body.  

To create a revolved surface 

1. Advanced experience level  

2. Do one of the following:  

Pull-down menu: DRAW > MODELING> Revolve  

 Toolbar:  

 Command: REVOLVE 
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3. Select the entity to revolve.  

4. Select the entity to be used as the axis of revolution.  

5. Specify the starting angle.  

6. Specify the number of degrees to revolve the entity.  

11.7. Creating Boxes 
You can create a rectangular box, or cube. A box consists of six rectangular surface 

planes. The base of the box is always parallel to the xy plane of the current UCS. You 

position the box by specifying either a corner or the center of the box. You determine 

the size of the box by either specifying a second corner and the height; defining the box 

to be a cube and then providing its length; or specifying the length, width, and height. 

To create a box 

1. Do one of the following:  

Pull-down menu: DRAW > MODELING > Box.  

Toolbar:  

Command: BOX 
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2. Specify the first corner of the base.  

3. Specify the opposite corner of the base.  

4. Specify the height.  

 

11.8. Creating Wedges 
You can create a three-dimensional wedge consisting of five surface planes. The base of 

the wedge is always parallel to the xy plane of the current UCS with the sloped face 

opposite the first corner. The height is always parallel to the z-axis. You position the 

wedge by specifying either a corner or the center of the wedge. You determine the size 

of the wedge by either specifying a second corner and the height; defining the wedge 

based on a cube having a given length; or specifying the length, width, and height. 

To create a wedge 

1. Do one of the following:  

Pull-down menu: DRAW > MODELING > Wedge.  

Toolbar:  

Command: WEDGE 
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2. Specify the first corner of the base.  

3. Specify the opposite corner of the base.  

4. Specify the height.  

 

11.9. Creating Cones 
You can create a three-dimensional cone defined by a circular base and tapering to a 

point perpendicular to the base. The base of the cone is always parallel to the xy plane 

of the current UCS; the height of the cone is always parallel to the z-axis. You position 

the cone by specifying the center of the base. You determine the size of the cone by 

specifying either the radius or the diameter of the base and the height. 

To create a cone 

1. Do one of the following:  

Pull-down menu: DRAW > MODELING > Cone.  

Toolbar:   

Command: CONE 



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 161

 
2. Specify the center of the base of the cone.  

3. Specify the radius or diameter.  

4. Specify the height.  

 

11.10. Creating Pyramids 
You can create a tetrahedron (three-sided pyramid) or a four-sided pyramid. The sides of 

the resulting pyramid can meet at a point (the apex) or can form a three- or four-edged 

top. The sides of a four-sided pyramid can also meet along a ridge defined by two points. 

The base of the pyramid is always parallel to the xy plane of the current UCS. You 

position the pyramid by specifying a corner of the base. You determine the size of the 

pyramid by specifying the base points and either the apex, the corners of the top surface, 

or the endpoints of the ridge. 

To create a tetrahedron 

1. Do one of the following:  

 Pull-down menu: DRAW > MODELING > Pyramid.  

 Toolbar:  
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 Command: PYRAMID  

 
2. Specify the first point for the base of the pyramid.  

3. Specify the second and third points.  

4. In the prompt box, choose Tetrahedron.  

5. Specify the apex of the tetrahedron. 

 

11.11. Creating Cylinders 
You can create a cylinder defined by a circular base. The base of a cylinder is always 

parallel to the xy plane of the current UCS; the height of a cylinder is always parallel to 

the z-axis. You position a cylinder by specifying the center of the base. You determine 

the size of a cylinder by specifying either the radius or diameter of the base and the 

height. 

Create a cylinder 

1. Do one of the following:  

Pull-down menu: DRAW > MODELING >Cylinder.  

Toolbar: .  

Command: CYLINDER  
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2. Specify the center of the base of the cylinder.  

3. Specify the radius or diameter.  

4. Specify the height.  

 

11.12. Creating Spheres 
You can create a sphere. The latitude lines of a sphere are always parallel to the xy plane 

of the current UCS; the central axis is always parallel to the z-axis. You position a 

sphere by specifying its center point. You determine the size of a sphere by specifying 

either its radius or its diameter. 

To create a sphere 

1. Do one of the following:  

Pull-down menu: DRAW > MODELING > Sphere.  

Toolbar:  

Command: SPHERE  
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2. Specify the center of the sphere.  

3. Specify the radius or diameter.  

 

 

11.13. Creating Torus 
You can create a three-dimensional donut or ring-shaped entity known as a torus. The 

diameter of a ring is always parallel to the xy plane of the current UCS. A torus is 

constructed by revolving a circle about a line drawn in the plane of the circle and 

parallel to the z-axis of the current UCS. You position a torus by specifying its center 

point. You determine the size of a torus by specifying its overall diameter or radius and 

the diameter or radius of the tube (the circle being revolved). 

To create a torus 

1. Do one of the following:  

Pull-down menu: DRAW > MODELING > Torus.  

Toolbar:  

Command: TORUS  
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2. Specify the center of the whole torus.  

3. Specify the radius or diameter of the whole torus.  

4. Specify the radius or diameter of the body of the torus.  

 

11.14. Editing in Three Dimensions 
 
You can copy, move, rotate, array, mirror, and align two-dimensional and 

three-dimensional entities in both two-dimensional and three-dimensional space. You 

can also change and edit properties of three-dimensional entities much like you change 

and edit properties for two-dimensional entities. When you modify three-dimensional 

entities in two-dimensional space, you modify the entity in relation to the current UCS.  

11.14.1. Rotating in Three Dimensions 
You can rotate selected entities about a specified axis in three-dimensional space. You 

select the entities to rotate and then define the axis of rotation either by specifying two 

points; selecting an existing entity; aligning the axis with the x-, y-, or z-axis of the 

current UCS; or aligning the axis with the current view. 

To rotate an entity about an axis in three dimensions 
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1. Do one of the following:  

Pull-down menu: Modify >3D Operation >3D Rotate.  

Toolbar:   

Command: ROTATE3D 

 
2. Select the entities to rotate, and then press Enter.  

3. Choose from one of the following options: Entity, Last, View, Xaxis, Yaxis, Zaxis.  

4. Specify the rotation angle.  

5. Specify the reference angle.  

 

 

11.14.2. Arraying in Three Dimensions 
You can copy selected entities and arrange them in a three-dimensional rectangular or 

polar (circular) pattern. For a rectangular array, you control the number of copies in the 

array by specifying the number of rows and columns and the number of levels. You also 

specify the distance between each. For a polar array, you specify the axis around which 
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to array the entities, the number of copies of the entities to create, and the angle 

subtended by the resulting array. 

To create a three-dimensional rectangular array 

1. Do one of the following:  

Pull-down menu: Modify>3D Operation > 3D Array.  

Command: 3DARRAY  

 
2. Select the entities, and then press Enter.  

3. In the prompt box, choose Rectangular.  

4. Type the number of rows in the array.  

5. Type the number of columns.  

6. Type the number of levels.  

7. Specify the vertical distance between the rows.  

8. Specify the horizontal distance between the columns.  

9. Specify the depth between the levels.  

 

11.14.3. Mirroring in Three Dimensions 
You can create a mirror image of selected entities in three-dimensional space. You 
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mirror the entities about a mirror plane that you define by either specifying three points; 

selecting an existing two-dimensional planar entity; aligning the plane parallel to the xy, 

yz, or xz plane of the current UCS; or aligning the plane with the current view. You can 

delete or retain the original entities. 

To mirror an entity about a three-dimensional plane 

1. Do one of the following:  

Pull-down menu: Modify>3D Operation > 3D Mirror.  

Command: MIRROR3D  

 
1. Select the entities, and then press Enter.  

2. In the prompt box, choose 3 Points, or press Enter to select the default.  

3. Specify the first point on the mirror plane.  

4. Specify the second and third points on the plane.  

5. In the prompt box, choose one of the following:  

 Yes-Delete Entities to delete the original entities.  

 No-Keep Entities to retain the original entities.  
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11.14.4. Aligning in Three Dimensions 
You can align selected entities with other entities in three-dimensional space. You select 

the entities you wish to align, and specify one, two, or three pairs of points to align the 

selected entities. 

To align an entity an entity with another  

1. Do one of the following:  

Pull-down menu: Modify>3D Operation >Align.  

Command: ALIGN.  

 
1. Select the entities, and then press Enter.  

2. Specify the first source point.  

3. Specify the first destination point.  

4. Specify additional source and destination points if desired (up to three pairs).  
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Chapter 12 Print Drawings 
12.1. Print Introduction and Interface 

Toolbar:  

Pull-down menu: File>Plot 

Command: Print 

 
The print interface of GstarCAD2010 is similar to AutoCAD basically.  

 
A：select a printer or plotter  

B：Set print driver 

C：Partial preview  

D：Choose and set plot style 

E：Specify the area to plot  

F：Set plot scale  

G：Set Drawing orientation  
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In GstarCAD2010, you can choose to install GstarCAD2010 built-in print driver which 

does not exist in the previous version. Your print work will become more conveniently, 

more smoothly, more accurately, if you use the built-in driver to print. 

12.2. Select a Printer or Plotter 
Before plotting a drawing, you must select a printer or plotter. The device you select 

affects the printable area of the drawing. 

After selecting a printing or plotting device, you also can easily plot a drawing using the 

default settings in the Plot dialog box. 

In this pull-down list, it contains not only the system print driver but also the 

GstarCAD2010 built-in print driver. You can install ICAD2010 built-in print driver 

through choosing “Add Plotter….” The process is below: 

 

 
Click “next” then choose “my computer” 
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Click “next”, choose a producer from the left table then choose a model from the right 

table. 

 
Click “next” you will see: 

 
Click “next” then choose “plot to port” or “print to file” according to your need. Many 

plotter choose to use LPT1 port currently.  
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You can finish the install work according to the prompts. 

12.3. Add DWF virtual print driver  
It can realize the web publish function, different from the direct DWF export before, 

this published file contains all the DWF information and users can export DWF file 

according to selected area 

The process of creating DWF file 

Select “DWF6 ePlot.pc3” printer, other steps are same to the normal print. 

 

12.4. Set the Print Driver 
Click “properties” then you can enter into the interface of print driver setup.  
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Click “Custom Properties” then you can set print driver and paper. 

 

 
If you use GstarCAD2010 built-in print driver you can set the valid area size and the 

margin; but if you use the system print driver you can not do this. 

12.5. Specify the Area to Plot 
When plotting a drawing, you must specify the area of the drawing to plot. The Plot 

dialog box provides the following options under Plot Area. 
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 Limits: When plotting a layout, plot everything within the printable area of the 

specified paper size, with the origin calculated from 0, 0 in the layout. When plotting 

the Model tab, plot the entire drawing area defined by the grid limits. If the current 

viewport does not display a plan view, this option has the same effect as the Extents 

option.  

 Display: Plot the view in the current viewport in the Model tab or the current paper 

space view in a layout tab.  

 Window: Plot any portion of the drawing you specify. Click the Window button to 

use a pointing device to specify opposite corners of the area to be plotted, or enter 

coordinate values. 

The settings in the “Plot Offset” area of the Plot dialog box specify an offset of the plot 

area relative to the lower-left corner (the origin) of the printable area or the edge of the 

paper, depending on the setting made in the Specify Plot Offset Relative To option 

(Options dialog box, Plot and Publish tab). The Plot Offset area of the Plot dialog box 

displays the specified plot offset option in parentheses.  

You can offset the drawing on the paper by entering positive or negative values in the X 

and Y offset boxes. However, this may result in the plot area being clipped.  

12.6. Set Plot Scale and Set Drawing Orientation  
Set Plot Scale 

When you specify a scale to output your drawing, you can choose from a list of 

real-world scales, enter your own scale, or select Fit to Paper to scale the drawing to fit 

onto the selected paper size. 

Usually, you draw objects at their actual size. That is, you decide how to interpret the 

size of a unit (an inch, a millimeter, a meter) and draw on a 1:1 scale. For example, if 

your unit of measurement is millimeters, then every unit in your drawing represents a 

millimeter. When you plot the drawing, you either specify a precise scale or fit the 

image to the paper. 

Most final drawings are plotted at a precise scale. The method used to set the plot scale 

depends on whether you plot the Model tab or a layout: 

 On the Model tab, you can establish the scale in the Plot dialog box. This scale 

represents a ratio of plotted units to the world-size units you used to draw the model.  

 In a layout, you work with two scales. The first affects the overall layout of the 
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drawing, which usually is scaled 1:1, based on the paper size. The second is the scale of 

the model itself, which is displayed in layout viewports. The scale in each of these 

viewports represents a ratio of the paper size to the size of the model in the viewport. 

Set Drawing Orientation 

The drawing orientation determines whether the position of the plotted drawing is 

landscape (the longer edge of the drawing is horizontal) or portrait (the longer edge of 

the drawing is vertical). This is based on the size of paper selected. You can also choose 

to plot upside down.  

12.7. Choose Plot Style  
A plot style controls how an object or layer is plotted by determining plotted properties 

such as lineweight, color, and fill style. Plot style tables collect groups of plot styles. 

The Plot Style Manager is a window that shows all the plot style tables available.  

There are two plot style types:  

Color-dependent and named: A drawing can use only one type of plot style table. You 

can convert a plot style table from one type to the other. You can also change the type of 

plot style table which has been set before. For color-dependent plot style tables, an 

object's color determines how it is plotted. These plot style table files have .ctb 

extensions. You cannot assign color-dependent plot styles directly to objects. Instead, to 

control how an object is plotted, you change its color. For example, all objects assigned 

the color red in a drawing are plotted in the same way.  

Named plot style tables: use plot styles that are assigned directly to objects and layers. 

These plot style table files have .stb extensions. Using them enables each object in a 

drawing to be plotted differently, independent of its color. 

ICAD2010 support pcp file , stb file and ctb file . You can choose the plot style files that 

have been designed, Users can also customize related setup.      
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You can choose a stb or ctb plot style in this pull-down list. If you want to use other ctb 

or stb plot style, you can copy the ctb or stb files to C:\Program Files\GstarCAD2010 

Professional\PrintStyles.         

You can open the Plot Style Table Editor by click  icon, The Plot Style Table Editor 

displays the plot styles contained in the specified plot style table. 

 
In this dialog box you can set the related parameters about plot style, such as color, 

linewidth. 

1. Set Color, Screening, Grayscale, and Dither in Plot Style Tables 

You can use a plot style to assign color, screening, grayscale, and dither properties. 

 Assign Plot Style Colors 

The default setting for plot style color is Use Object Color. With this setting, the object 
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retains its layer or individually set color. If you assign a plot style color, the color 

overrides the object's color at plot time. You can specify one of 255 ACI colors, a true 

color, or a color book color. The plotter must be configured for True Color if you want 

to plot True Color plot styles. 

 Use Screening 

You can select a color intensity setting that determines the amount of ink placed on the 

paper while plotting. The valid range is 0 through 100. Selecting 0 reduces the color to 

white. Selecting 100 displays the color at its full intensity. Screening is effective only if 

your plotter is configured to plot colors or grayscale. Also, dithering must be enabled. 

 Use Dithering 

A plotter uses dithering to approximate colors with dot patterns, giving the impression 

of plotting with more colors than the ink colors available in the plotter. If the plotter 

does not support dithering, the dithering setting is ignored. 

 Convert to Grayscale 

When you select Convert to Grayscale, the object's colors are converted to grayscale if 

the plotter supports grayscale. Light colors, such as yellow, are plotted with light gray 

values. Dark colors are plotted with dark gray values. If you clear Convert to Grayscale, 

the RGB values are used for the object's colors. Conversion to grayscale is available 

whether you use the object's color or assign a plot style color. 

2. Assign Pens to Plot Styles 

The Use Assigned Pen Number setting in the Plot Style Table Editor specifies which 

physical pen to use for each plot style.  

3. Control Plotted Lineweight and Linetype 

Both lineweight and linetype can be set as an object property or controlled when plotted 

by using a plot style. Lineweight or linetype settings in the plot style override the 

object's lineweight or linetype at plot time. 

 Assign and Display Lineweights 

When you select the Lineweight field in the Plot Style Table Editor, a sample of the 

lineweight as well as its numeric value are displayed. The default setting for plot style 

lineweight is Use Object Lineweight. You can modify an existing lineweight if the one 

you need is not available. 

 Assign Linetypes 
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When you select the Linetype field in the Plot Style Table Editor, a list with a sample 

and a description of each linetype are displayed. The default setting for plot style 

linetype is Use Object Linetype. 

4. Assign Plotted Line End and Join Styles 

You can set the line end and join styles for objects that have lineweight assigned, either 

as an object property or as a plot style override. 

 Assign Line End Style 

The default setting for Line End Style is Use Object End Style, which is rounded. 

Assign a line end style in a plot style to override the object's default line end style at 

plot time. 

 Assign Line Join Style 

The default setting for Line Join Style is Use Object Join Style, which is rounded. 

Assign a line join style in a plot style to override the object's default line join style at 

plot time. 

5. Assign Plotted Fill Styles 

You can assign a variety of fill style options when plotting wide polylines, donuts, 

objects hatched with a solid fill, and solids. 

The default setting for Fill Style is Use Object Fill Style. Assign a fill style in a plot 

style to override the object's fill style at plot time. 

You can apply a global scale factor to non-ISO linetypes and fill patterns in plot styles. 

12.8. Preview a Plot 
It is good practice to generate a preview of the plotted drawing before sending the 

drawing to the printer or plotter. 

You can preview the drawing from the Plot dialog box. The preview shows exactly how 

the drawing will look when plotted, including lineweights, fill patterns, and other plot 

style options. 

When you preview your drawing, the active toolbars and tool palettes are hidden and a 

temporary Preview toolbar is displayed that provides buttons to plot, pan, and zoom the 

drawing. 

Pull-down menu: File>Plot Preview 

Toolbar:  

Command: Preview 



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 181
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Chapter 13 Express Tools 

13.1. Layer 
(GstarCAD LT Standard and Professional version don’t include the following functions) 
 
13.1.1. Layer Manager 
Manage layer settings by allowing you to save and restore layer configurations into 

layer states. Layer states can be modified, restored, or renamed. Layer states are saved 

in the drawing, but they can also be exported to or imported from a LAY file. 

 
Save: Save the current layer settings into the selected layer state. If a new name is 

specified, a new state is created.  

Edit: Display the Layer Properties Manager dialog box, where changes can be made to 

the selected layer state. If no layer states exist, a new one is created.  

Rename: Rename a layer state.  

Delete: Delete a layer state and displays the following message: Are you sure you want 

to delete <layer state name>?  

Import: Display the Import File Name dialog box to specify a LAY file name, drive, 

and directory for importing into the current drawing. A Find File button opens the 

Browse/Search subdialog box to locate saved .lay files.  

Export: Display the Export File Name dialog box to specify a LAY file name, drive, 

and directory for exporting from the current drawing.  

Options: Set options to use for layer status restore operations. This option allows you to 

specify the layer properties to be restored (on/off, freeze/thaw, color, linetype, and so 

on).  

Restore:  Restores the layer settings in the selected layer state without closing the 
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dialog box.  

Help Provides help for the Layer Manager. 

13.1.2. Layer Walk 
Dynamically displays objects on selected layers  

Pull-down menu: Express>Layer> Layer Walk 

 
Displays objects on layers when the layer names are selected in the dialog box. The 

number of objects on the selected layers and the number of layers in the drawing are 

displayed. With this tool, you can alter the layer state when you exit, save layer states, 

and purge layers that are not unreferenced. 

 
LAYWALK Dialog Box Options 

Filter: Turns the active filter on and off. When this checkbox is selected, the list 

displays the layers that match the active filter. When this checkbox is cleared, the full 

list of layers is displayed. (This option is not available when there is no active filter.)  

Purge: Purges layers that are not referenced from the current selection. This button is 
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unavailable if the current selection does not contain one or more unreferenced layers. 

For a list of layers that can be purged, choose Select Unreferenced from the shortcut 

menu.  

Restore on Exit: If this option is selected, the layers are returned to their previous state 

when you exit the command.   

Select Objects: Using this button, you select objects on the screen in order to select 

their layers.   

13.1.3. Layer Match 
Change the layer(s) of selected object(s) to match the layer of a selected destination 

object.  

Pull-down menu: Express>Layer>Layer Freeze 

Command: LAYMCH 

 
Usage Example: 

Select an object, such as a door, whose layer assignment you want to change; then select 

an object on the layer you want to match.  

Command: LAYMCH 

Select objects: Select the doors for the layers to be changed 

Select objects: Press ENTER when you finish selecting objects 

Select object on destination layer or [Type-it]: Select the door on layer N_DOOR to 

match 

2 objects changed to layer N-DOOR. 
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13.1.4. Change to Current Layer 
Change the layer of one or more objects to the current layer.  

Pull-down menu: Express>Layer> Change to Current Layer 

Command: LAYCUR 

Select objects to be changed to the current layer: 

Select objects: Use an object selection method 

 

 
Usage Example: 

Select objects, such as the chairs on the layer CHAIR, and change them to the current 
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layer, FURN.  

Command: LAYCUR 

Select objects to be changed to the current layer: 

Select objects: Specify the object(s) you want changed to the current layer 

Select objects: Press ENTER when you finish selecting objects 

1 object(s) changed to layer LAYER1 (the current layer).  

13.1.5. Copy Objects to New Layer 
Copies selected objects to a different layer, leaving original objects intact. 

You can select the target layer from a list of current layers, or you can create a new 

layer.  

Pull-down menu: Express>Layer> Copy Objects to New Layer 

Command: COPYTOLAYER 

Select objects: Specify object(s) you want to copy to a different layer 

 

 

 
COPYTOLAYER Dialog Box Options 
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To specify the destination layer, you can select a current layer from the list or type a 

new layer name in the text box. 

13.1.6. Layer Isolate 
Isolate the layer(s) of one or more selected objects by turning all other layers off.  

Pull-down menu: Express>Layer> Layer Isolate 

Command: LAYISO 

 

 
Select object(s) on the layer(s) to be isolated: 

Select objects: Use an object selection method 

Usage Example: 

Select an object, such as the hatch pattern, whose layers you want to isolate.  

Command: LAYISO 

Select object(s) on the layer(s) to be isolated: 

Select objects: Specify the object(s) whose layers are to be isolated 
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Select objects: Press ENTER when you finish selecting objects 

Layer A-HATCH has been isolated. 

 

13.1.7. Layer off and Turn All Layers On 
Layer Off: Turns off the layer of selected object(s).  

Turn All Layers On: Turns on all layers 

13.1.8. Layer Freeze and Thaw all Layers 
Layer Freeze: Freezes the layer of the selected object(s).  

Thaw all Layers: Thaws all layers 

13.1.9. Layer Lock and Layer Unlock 
Layer Lock: Locks layer of the selected object. 

Layer Unlock: Unlocks layer of the selected object. 
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13.1.10. Layer Merge 
Moves all objects on the first layer selected onto the second layer selected. The first 

layer will be purged from the drawing. 

Pull-down menu: Express>Layer>Layer Merge 

Command: LAYMRG 

Usage Example: 

Select an object whose layer you want to merge into another layer.  

Command: LAYMRG 

Select object on layer to merge or [Type-it/Undo]: Select sofa on layer SOFA 

Selected layers: SOFA 

Select object on layer to merge or [Type-it/Undo] <done>: Press ENTER 

Select object on target layer or [Type-it]: Select a table on layer FURN 
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13.1.11. Layer Delete 
Deletes all objects from the specified layer and purges the layer from the drawing.  

Pull-down menu: Express>Layer>Layer Delete 

Command: LAYDEL 

Select object on layer to delete or [Type-it/Undo]: Use an object selection method for 

the layer to delete, or enter T to type the layer name 
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Usage Example: 

Select an object to delete a layer.  

Command: LAYDEL 

Select object on layer to delete or [Type-it/Undo]: Select a plant on the PLANTS layer 

Selected layers: PLANTS  

Select object on layer to delete or [Type-it/Undo] <done>: Press ENTER 

 

13.1.12. Layer Object Change Color and Layer Object Move 
Layer Object Change Color: After picking objects, you can change the layer color 

through inputting 1, you can change objects color through inputting 0 

Layer Object Move: You can obtain layer information after picking objects, then you 

can choose and move the other objects which are in the same layer with the picked 

objects.  

13.1.13. Current Layer Setting 
Set the layer which contains the picked objects current layer. 
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13.2. Blocks 
(GstarCAD LT Standard and Professional version don’t include the following functions)   
              

13.2.1. List Xref/Block Properties 
List the type, block name, layer name, color and linetype of a nested object in a block or 
an xref.  
Command: XLIST 
Usage Example: 

Select an object as a nested block or xref file to display the Object and Block Name, 

Layer, Color, and Linetype properties. 

Command: XLIST 

Select nested xref or block object to list: 

 

 
13.2.2. Copy Nested Objects 

Copy objects nested in an xref or a block. 

Command: NCOPY 

13.2.3. Trim to Nested Objects 
Uses a block (or entities within a block reference) as a boundary to trim objects in a 

drawing 

Command: BTRIM 

13.2.4. Extend to Nested Objects 
Use a block (or entities within a block reference) as a boundary to extend objects in a 

drawing. 
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Command: BTRIM 

13.2.5. Explode Attribute to Text 
Explode blocks, converting attribute values to text objects. 

Command: BURST 

13.2.6. Export Attribute Information 
Export block attribute values to an external file in tab-delimited ASCII format. 

Command: ATTOUT 

13.2.7. Import Attribute Information 
Import block attribute values from an external, tab-delimited ASCII file. 

Command: ATTIN 

13.2.8. Convert BLOCK to XREF 
Replace all instances of a standard block with an xref. Unbinds xrefs that are bound.  

Command: BLOCKTOXREF 

13.2.9. Replace Block with Another Block 
In the current drawing, you can use one block to replace anther block 

Command ：BLOCKREPLACE 
13.2.10. BLOCKREPLACE  
Allow you to globally replace all inserts of one block with another block.  

BLOCKREPLACE searches the entire drawing for a specified block and replaces it 

with another block that you specify. You can have the unreferenced block purged when 

done.  

Specify the block name to search for by selecting it in the list or by clicking the Pick 

button and selecting a block in the drawing:  
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Specify the replacement block: 

 

13.2.11. Statistics Blocks Number 
You can statistics the number of various blocks through this function. 

13.3. Text 
(GstarCAD LT Standard and Professional version don’t include the following functions) 
 

13.3.1. Text Fit 
Stretch or shrink text object(s) by selecting new start and/or end points.  

Command: TEXTFIT 

Usage Example: 

Fit labels within enclosed borders by setting a new text width. 
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Select text 

 
Select a new endpoint 

 
Text size shrinks 

 

13.3.2. Text Mask 
Place a mask object behind selected text or mtext. The rectangular mask is offset from 

the text by a specified value.  

Command: TEXTMASK 

13.3.3. Text Unmask 
Remove mask from text that has been masked with the TEXTMASK command.  

Command: TEXTUNMASK 

13.3.4. Arctext  
Place text along an arc.  

Dialog Box Options 
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Pick boxes: Set controls for text location relative to the arc and its length. The Drag 

Wizard controls the behavior of the text when the arc is moved.  

Color: Specify the text color.  

Text: Specifies the text.  

Style Name: Specify the style name for a selected font. Also specifies bold, italic, and 

underline settings.  

Font: List the TrueType fonts and compiled shape (SHX) fonts  

Properties Section: Specify the text height, width factor, character spacing, offset from 

arc, offset from left, and offset from right.  

 

Usage Example 

Draw an arc, and then use ARCTEXT to place text along the arc's curve.  

 

13.3.5. Rtext  
Creates reactive text  

Reactive text (RText) objects are displayed the same way normal Text or MText objects 

are displayed, but the source for the text is either an external text file or the value of a 

DIESEL expression. You can edit an RText object with the RTEDIT command.  

Command: RTEXT 

Enter an option [Style/Height/Rotation/File/Diesel] <Diesel>: Specify an option 
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Options 

Style: Select a text style.  

Height: Specify a text height.  

Rotation: Specify a rotation value.  

File: Use an external text file.  

Diesel: Use DIESEL code. 

13.3.6. Rtedit 
Allows you to edit existing remote text (Rtext) objects  

13.3.7. Justify Text 
Change a text object's justification without changing its position. Works with text, mtext, 

and attribute definition objects. 

Command: TJUST 

Select objects: Use an object selection method 

[Start/Center/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR] <Start>:Choose the 

new justification 

Usage Example: 

Covert text to middle justified  

Text left justified: 

 
 

Text after justification change: 
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13.3.8. Rotate Text 
Aligns text, mtext and block attribute objects to new orientation  

Rotates text, mtext, and attribute definition objects so that they end up being as close as 

possible to horizontal or right-read (similar to the behavior of dimension text). Objects 

are rotated about their middle point in 180-degree increments. For example, if the text is 

upside-down, it becomes right-side up after a TORIENT operation. Similarly, left-read 

text becomes right-read text. The overall object location is not changed. As an option, 

you can specify a new absolute orientation angle for all selected text objects.  

Command: TORIENT 

Select objects: Use an object selection method 

New absolute rotation <Most readable>: Enter an absolute angle or press ENTER 

Rotation Options 

New absolute rotation: Enter a new absolute orientation angle for all selected text  

Most Readable: Orients selected text objects to the most readable right-side-up, 

right-read orientation  

Usage Example:  

Text before rotation:  

 
Text after rotation - most readable option: 
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Text after rotation - specified angle of 0 degrees: 

 

13.3.9. Enclose Text with Object 
Place a circle, a slot, or a rectangle around each selected text or mtext object.  

The diameters of the circles can be constant or fitted to each object. The width and 

height of the slots and rectangles can be constant or variable.  

Command: TCIRCLE 

Usage Example:  

Circles: Constant radius:  
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 Circles: Variable radius: 

 

13.3.10. Tcount  
Add sequential numbering to text objects. The numbering can appear as a prefix, suffix 

or replacement text.  

Command: TCOUNT 

Select objects: Use an object selection method 

Sort selected objects by [X/Y/Select-order] <Select-order>: 

Sorting Options 

X:  Places numbers by increasing the x-coordinate value of the selected text.  

Y:  Places numbers by decreasing the y-coordinate value of the selected text.  

Select-order: Places numbers according to the order in which the text was selected. 

Usage Example:  

 

13.3.11. Change Text Case 
Change the case of selected text, mtext, attributes and dimension text.  

Command: TCASE 

Select objects:  
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13.3.12. Convert Text to Mtext 
Convert one or more lines of text to mtext.  

Command: TXT2MTXT 

Select text objects or press Enter to set Options: 

Select objects: Use an object selection method to select text 

Usage Example: 

Select three text objects and convert them to mtext objects.  

Select text items: 

 
Text converted to mtext: 

 

13.4. Dimension 
(GstarCAD LT Standard and Professional version don’t include the following functions) 
 
13.4.1. Attach Leader to Annotation 
Attach leader line to mtext, tolerance, or block reference object.  
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Command: QLATTACH 

Select Leader: Select a leader 

Select Annotation: Select the mtext, tolerance, or block reference object for the 

annotation 

Usage Example: 

Select a leader line, and then specify the mtext object to attach.  

Separate leader line and mtext objects: 

 
Leader line with mtext attached as one object: 

 

13.4.2. Detach Leaders from Annotation 
Detach leader line from mtext, tolerance, or block reference object.  

Command: QLDETACHSET 

Select objects: Select leader line 

Usage Example: 

Select a leader line to detach from an mtext object.  

Leader with mtext object attached:  

 
Leader detached from the mtext object, which can then be moved 
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13.4.3. Global Attach Leader to Annotation 
Globally attaches leaders line to mtext, tolerance, or block reference objects 

Command: QLATTACHSET 

Select objects: Select one or multiple leader lines and annotation objects 

Usage Example: 

Select leader line(s), and mtext objects to attach.  

Select objects: Select one or multiple leader lines and annotation objects 

Number of Leaders = 2 

Number with annotation detached = 2.  

Leader with detached mtext object:  

 
Leader attached to mtext object: 

 

13.4.4. Dimstyle Export 
Exports named dimension styles and their settings to an external file. 
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DIMEX Dialog Box Options 

Export Filename: Creates of opens a DIM file. Enter the DIM file name or select 

Browse to locate the file. If the file does not exist, it is created. If the file does exist, a 

prompt requests permission to overwrite. The new file is an ASCII file.  

Available Dimension Styles: Selects the dimension styles to write to the ASCII file. 

The current dimension styles are displayed. Each selected style is written to the file 

indicated in the Export Filename group.  

Text Style Options Saves either the dimension's Full Text Style Information or the Text 

Style Name Only to the ASCII file. 

13.4.5. Dimstyle Import 
Imports named dimension styles from a DIM file into the current drawing.  

 
 DIMIM Dialog Box Options 

Import Filename: Names the file you want to import. Enter an existing file name or 

select Browse to specify a DIM file to import. The file must be of the form generated by 

the corresponding DIMEX command. All dimension styles in the selected file are 

imported into the current drawing. Text styles are also imported.   
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Import Options: Includes Keep the Existing Style, to keep the dimension style in the 

current drawing and Overwrite Existing Style, to overwrite styles in the current drawing. 

The Keep the Existing Style option ignores the similarly named style being imported; 

Overwrite Existing Style uses the similarly named style being imported.   

13.4.6. Reset Dim Text Value 
Restore a measurement value to overridden or modified dimension text.  

Command: DIMREASSOC 

13.4.7. Update Dimension 
You should select a base 

You should select a standard dimension at first; then update other dimension to the 
standard dimension with the same settings 

Command: Dimupdate 

13.4.8. Change Dimension Text 
Command: Chgdimtxt 

Change the dimension content into the specified value 

13.4.9. Change Dimstyle 
Command: Dimstyle 

Apply the current dimension style to the dimensions in the drawing  

13.5. Selection Tools 
(GstarCAD LT Standard and Professional version don’t include the following functions) 

13.5.1. Get Selection Set 
Create a temporary selection set of objects. 

Command: GETSEL 

Select an object on the Source layer <*>: Use a selection set method or press ENTER 

for all layers 

Select an object of the Type you want <*>: Use a selection set method or press ENTER 

for all object types 

13.5.2. Filtrate Selection 
Select, edit, and name filters for object selection. 

Command: Filter 
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Options: 

1. X, Y, Z Parameters 

Define additional filter parameters depending on the object.  

In the filter parameters, you can use relative operators such as < (less than) or > (greater 

than).  

2. Select 

Display a dialog box listing all items of the specified type in the drawing. Select the 

items to filter.  

3. Add to List 

Add the current Select Filter property to the filter list. Filter properties that you add to 

the unnamed filter remain available during the current work session unless you 

manually delete them. 

4. Replace 

Replace the filter property selected in the filter property list with the one displayed in 

Select Filter. 

5. Add Selected Object 

Add one selected object in the drawing to the filter list. 

6. Edit Item 

Move the selected filter property into the Select Filter area for editing. To edit a filter 

property, select it and choose Edit Item. Edit the filter property and choose Substitute. 

The edited filter replaces the selected filter property. 

7. Delete 

Delete a selected filter property from the current filter. 

8. Clear List 

Delete all the listed properties from the current filter. 
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9. The filter name is used 

Displays, saves, and deletes filters. 

10. Current 

Display saved filters. Select a filter list to make it current. The named filter and its list 

of properties are loaded from the default file, filter.nfl. 

11. Save As 

Save a filter and its list of properties. The filter is saved in the filter.nfl file. Names can 

contain up to 18 characters.  

12. Delete Current Filter List 

Delete a filter and all its properties from the default filter file.  

13. Apply 

Exit the dialog box and displays the Select Objects prompt, where you create a selection 

set. The current filter is used on the objects you select. 

13.6. Modify 
(GstarCAD LT Standard and Professional version don’t include the following functions) 

13.6.1. Move/Copy/Rotate 
Move, copy, rotate, and scales object(s) with a single command.  

Command: MOCORO 

Select objects: Use an object selection method 

Base point: Specify a base point 

[Move/Copy/Rotate/Scale/Base/Undo]<eXit>: Specify an option 

Options 

Move: Move object(s).  

Copy: Make multiple copies of object(s).  

Rotate: Rotate object(s).  

Scale: Dynamically scale object(s).  

Base: Specifies a base point for object(s) to be moved, copied, scaled or rotated 

13.6.2. Multiple Copy 
Copy multiple objects with Repeat, Array, Divide and Measure options. 

Command: COPYM 

Select objects: Select the objects to be copied 
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Base point: Specify a base point 

Second point or [Repeat (last)/Divide/Measure/Array (dynamic)/Undo] <exit>: 

COPYM Options 

Repeat: Repeat the last copy using the same offset distance.  

Divide: Linear divide option. Prompt for an additional point and the number of copies 

to make. Makes evenly spaced copies of the selected objects between the base point and 

the second selected point.  

Measure: Linear measure option. Prompt for an additional point and the distance 

between copies. Makes evenly spaced copies at the specified distance between the base 

point and the second selected point.  

Array: Display the Array Options prompt 

13.6.3. Extended Offset 
This enhanced version of the OFFSET command offers several advantages over the 

standard command, including layer control, undo, and a multiple option.  

Command: EXOFFSET 

Specify offset distance or [Through] <T>: Specify the offset distance or through point 

Select object(s) to offset or [Options/Undo]: Select an object to offset, change options or 

undo 

Specify an option to set [Distance/Layer/Gaptype]: Specify a option 

EXOFFSET Options 

Distance: Specify the offset distance or through point  

Layer: Specify the layer for new objects. Current Layer or Source Object Layer  

GapType: Set or changes the offset mode as controlled by the OFFSETGAPTYPE 

variable. The options are: Normal, Fillet or Chamfer. 

13.6.4. Multiple Pedit 
This command is the same as the standard command nearly. 

Command: MPEDIT 

13.6.5. Cookie Cutter Trim 
Trim one side of a line which is intersecting a selected lines 

Command: EXTRIM 
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13.6.6. Full-Page Proof Cut Drawing 
This function is added according to user’s requirement .You can select a part of a 

drawing as full-page proof then copy it to a specified location. 

Command: ICAD_DYJT 

13.7. Draw 
(GstarCAD LT Standard and Professional version don’t include the following functions) 

13.7.1. Breakline Symbol 
Creates a polyline and inserts the breakline symbol.  

Command: BREAKLINE 

Options are provided to control the relative size and appearance of the breakline symbol 

and an extension of the polyline beyond the selected start and end points.  

Options 

Block: Determine the block to be used as the breakline symbol.  

Size: Determine the size of the breakline symbol.  

Extension: Determine the length of the line extension beyond selected points. 

13.8. Tools 
(GstarCAD LT Standard and Professional version don’t include the following functions) 

13.8.1. Xdata Attachment 
Attaches extended object data (xdata) to a selected object. 

Command: XDATA 

Select object: Use an object selection method 

Application name: Specify application name 

[3Real/DIR/DISP/DIST/Hand/Int/LAyer/LOng/Pos/Real/SCale/STr/eXit]<eXit>: Enter 

an option 

Options 

Application name: An ASCII string up to 255 bytes long (group code 1000).  

Layer: A layer name (group code 1003).  

Hand:  An object handle (group code 1005).  

3Real: 3 real numbers (group code 1010).  

Pos: A 3D World space position (group code 1011).  

Disp: A 3D World space displacement (group code 1012).  
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Dir: A 3D World space direction (group code 1013).  

Real: A real number (group code 1040).  

Dist: A distance (group code 1041).  

Scale: A scale factor (group code 1042).  

Int: A 16-bit integer (group code 1070).  

Long: A 32-bit signed long integer (group code 1071). 

13.8.2. List Entity Xdata 
Lists the xdata associated with an object.  

Command: XDLIST  

Select object: Use an object selection method 

Application name <*>: Specify an application name or press ENTER for all 

applications 

13.8.3. System Variable Editor 
Allows you to view, edit and save system variable settings. 

 
SYSVDLG Dialog Box Options 

List Box: Display a list of system variables. The edit field above the list box allows for 

filtering the list box display based on user input. For example, entering DIM* in the edit 

field filters the list to display only system variables that start with DIM. If nothing is 

entered in the edit field, the list displays all system variables. If more than one system 

variable is highlighted, all edit and display options are unavailable.  

New Value: Display the current value of the system variable highlighted in the list box 

and allows you to edit that value. No changes are committed until the dialog is closed 

with the OK button. If the selected variable is a read-only type, this edit field will be 

unavailable.  

Current Value: Display the value of the system variable highlighted in the list box as 
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of when SYSVDLG was started.  

Initial Value: Display the initial value of the system variable highlighted in the list box. 

This is the value the system variable has in a new drawing.  

Saved In: Display where the value of the highlighted system variable is saved.  

Type: Display the type of the highlighted system variable; for example, integer, real, 

string, and so on.  

Save All: Save the current system variable settings to an SVF or SCR file. SVF files can 

be read into SYSVDLG and SCR files are AutoCAD scripts that can be run from the 

AutoCAD command line. The button will display Save All, Save Selected or Save 

Filtered depending on the condition of the system variable list. If only one system 

variable is selected and the list is not filtered, all the system variables will saved. If 

more than one system variable is selected, only the highlighted items are saved. If the 

list has been filtered, as with a wild-card, the list is saved as displayed.  

Read: Restore saved settings from a SVF file.  

No changes are saved to the drawing until you choose OK. All pending changes can be 

discarded with the Cancel button. SYSVDLG will validate new system variable values 

as they are changed.  

13.8.4. Make Linetype 
Creates a linetype based on selected objects. 

Command: MKLTYPE 

13.9. Form Tools 
You can draw a form through dragging, then you can edit the form such as uniting form, 

comparting form, adding bias, adding one row, adding one column and etc, you can also 

fill in the form and adjust the text location. 

13.10. Coordinate Tools 
(GstarCAD LT Standard and Professional version don’t include the following functions) 

13.10.1. Coordinate Point 
Dimension the point coordinate on the drawing 

Command: DIMCOORD 

13.10.2. Change Z Coordinate 
You can choose several objects then change the Z coordinates at one time. 
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Command: CHANGEZ 

13.11. 3D View 
You can adjust viewport direction through this command. 

13.12. Drawing Tools 
(GstarCAD LT Standard and Professional, GstarCAD Regular Standard and Professional 

version don’t include the following functions) 
 

13.12.1. Drawing Compare 
Drawing compare is an exclusive function in GstarICAD which is added according to 

user’s requirement, Other CAD software has no the feature function.  

The Drawing Compare feature enhances collaboration by using color-coded displays to 

show items on a drawing that have been changed, added, or deleted by other members 

of the design team. Changes to items such as styles, fire ratings, or other non-graphical 

properties are also tracked. The Drawing Compare features make communication across 

the design team clearer than ever. 

Some engineers often meet such problems: sometimes they need to judge what 

amendments had been made between two drawings which were drawn at different time. 

The usual solution is to mark the amended contents with text. This way is difficult to 

drawer and reader.  

The function makes users convenient to locate the changed parts. The program will 

analyze the difference between the two drawings automatically, as long as you select the 

drawings that you want to compare. The difference will be marked with different colors. 

Users also can set the marking color by clicking “option” button. 

(1). Execute 

Pull-down Menu: Express>Drawing Tools>Drawing compare 

Command: CMP 

(2) The usage of the function 

1) Open the original drawing and the changed drawing 
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The original drawing 

 

 
The changed drawing 

2) Set the colors in the option dialog 

 
3) The below are the drawings which were compared 
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The old drawing 

 
The new drawing 

From the last two drawings you can see the amendments which have been marked with 

different colors. Drawing compare is developed according to users’ requirement, 

currently AutoCAD has no similar function. This function is very helpful to coordinate 

design between different fields. It saves much time from amending contents to reading 

drawings. It is very popular with engineers. 

13.12.2. Drawing Lock 
Designers often let others see own drawings, but don’t want others to modify the 

drawings at the same time. “drawing lock” function can make the drawing as a whole, if 

others want to modify the drawing he only can edit the whole drawing, and can not edit 

the specific entity, it is a good way to prevent others from modifying own drawing. 

Command：lockup 

Command prompt: Select objects 

At this time as long as you select all the entities in the current drawing 
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Note: Please make a copy for yourself before you use this function, because the drawing 

which is used for “drawing lock” is for others to see. 

13.13. Arrange Drawings Automatically 
(GstarCAD LT Standard and Professional , GstarCAD Regular Standard and 

Professional version don’t include the following functions) 

Many drawings can be arranged automatically through software calculation. It not only 

can enhance print efficiency but also can save paper. 

Command: ZDPT 

Menu: Express>Automatic row diagram 

 
Operation Steps: 

(1) If you use this function at first time, you should do some settings at “Option” item 

(2) Select the arranged file from “add file” item 

(3) After selecting the arranged file you can “tryout” these files, and preview the 

arranged effect. 
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13.14. PLT Output Tool 
(GstarCAD LT Standard and Professional , GstarCAD Regular Standard and 

Professional version don’t include the following functions) 

Users can send PLT files to printer to print. 

Operation Steps: 

1) Right-click GstarCAD icon>Properties>Find Target 

2) Select PrintPlt.exe in the dialog box 

 
3) Double-click the PrintPlt.exe file, then the “Print” dialog box will be displayed, 

in the dialog box you can select printer or do some settings. 

4) Click OK button, the “Open” dialog box is displayed, you can select the printed 

file. 
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13.15. HCCAD Tools 
(GstarCAD LT Standard and Professional , GstarCAD Regular Standard and 

Professional version don’t include the following functions) 
 
HaoChen Tools integrated many convenient drawing tools, user can use GstarCAD 

platform software to finish many professional design such as pipeline design. 

1) Drawing Scale 

Command：SASCL 

Set drawing scale before starting to draw, software will adjust the scale automatically 

when you use other tools such as modifying lineweight. 

2) Control Parameters——Cross to break width 

Command：CBKWID 

Set the width of fast tripping cross, about “the fast tripping cross” we will introduce it 

later 

3) Rotate Cursor 

Command：RTCUR 

Set the cursor to the angle that you want. You can choose 0 degree or 45 degree which 

have been set; you also can choose “Alongside Line” to select a line, the cursor angle 

will become corresponding with the line; If you select “Real Time Rotate” and it seems 

that you enter into a little play, you can use AWSD four key to control the rotate of the 

cursor till you press Enter to finish it  

4) Line Such as Chord 

Command：SALPL 

It is very convenient to use “Line such as chord” function to draw isometric drawing. 

Software will prompt you to input lineweight value, you can set the value according 

your need, then start to draw your entity, the graphic way is the same with drawing 

common multiline, software supplies the usually used angle 0 degree and 45 degree, 

you can set the angle value by yourself, it will feel the drawing process is fast and easy. 

The sample drawing is below: 
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5) Extension 

Command：ETT 

The extension location can be displayed in real-time until to the final location 

6) Normal Connect 

Command：GXFILT 

This function is similar with 0 distance chamfer. If there are two intersectant line or 

pline, the selected part will be retained and other part will be cut 

 
Select 1 and 2 to use “normal connect”, and so 3 and 4 will be cut, the effect is below 

 
7) Flex connect 

Command：GXFSS 

As long as two lines or pline are not parallel, they can realize “flex connect”, this 

function will make selected line extend to the location where it intersect with the target 

line or where it intersect with the extension line of the target line. The sample picture is 

below: 

Now use 1 with 2 and 1 with 3 to use this function separately  
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The situation before “Flex connect” 

    
1with 2 to use the function                1with3 to use the function 

8) Super Fillet 

Command：SFILLET 

Why we can this function “Super fillet”? because this function not only can finish 

the usual fillet operation but also can unify the two lines’ information such as layer、

color、line type and etc, the unified standard is according to the firstly selected line. 

 
In this drawing, these two lines have different color and line type, now we use super 

fillet function to theme. 

Please enter the Fillet radius<0>: 

The software will prompt you after you input the radius 

Please select the first line segment: 

The selected first lien will determine the layer、color and line type of filleted two lines, 
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here we select the green lien as the first line, then select the yellow line to do super fillet, 

the result is below: 

 
9) Modify linewidth 

Command：LCW 

Change the linewidth of specified pline, if you select a line and software will translate 

this line into pline and set linewidth automatically for it. It is very convenient to edit 

linewidth. 

10) Cross to break soon 

Command：CBK 

We often need to break many lines when drawing, but it is very unconvenient to do this 

by hand. This aim can be easily finished by this function supplied by GstarCAD 

Software will prompt you to select a line which is to break other lines namely the cover 

line segment then you can select the breaking lines. 

Use the green line as the cover line to break the red line and yellow line. The effect is 

below: 

 

    

 
11) Modify Text 
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Command：EDTXT 

Supply some functions to single text such as: height、text width factor、angle、obliquing 

angle 

12) Super Axonometric 

Command：ZC 

It is a very helpful function, you can translate plan drawing into isometric drawing 

easily with it. 

The operation way is very easy, you should select the translated drawing at first, then set 

the axonometric angle, at last press Enter to finish your operation. 

     
Before translation                                After translation 

 

 

13.16. AutoXlsTable 
AutoXlsTable can account block quantities, objects area and length. The data in the 

table will be updated automatically according to the modification of objects. 

(GstarCAD LT Standard and Professional , GstarCAD Regular Standard and 

Professional version don’t include the following functions) 

 
 

13.16.1. Create table 

1) On the Express Tools menu, point to AutoXlsTable, click Create AutoXlsTable.  



GstarCAD 2010 –Fluent Use in Entire Design 

www.staricad.com                        support @staricad.com 222

 

Or click Create AutoXlsTable button on the AutoXlsTable toolbar . 

 

2)         Specify insertion point. 

3)         Create an Excel spreadsheet or open an existing Excel spreadsheet in Excel. 

4)         On the AutoXlsTable menu, click Finish. 

Or click Finish button on the AutoXlsTable toolbar. 

 

图 1.1 1 

13.16.2. Edit table 

  1)   On the CADAddonTools menu, point to AutoXlsTable, click Edit AutoXlsTable. 

Or click Edit AutoXlsTable button on the AutoXlsTable floating toolbar. 
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2)         Select a table created by AutoXlsTable. 

13.16.3. Update table 
 Update table whose original Excel spreadsheet was modified 

1)         On the CADAddonTools menu, point to AutoXlsTable, click Update AutoXlsTable. 

Or click Update table button on the AutoXlsTable toolbar. 

 

2) Select the table to update. 

 Update table whose original Excel spreadsheet even contains automatic links to 

another Excel spreadsheet (.xls file) 

Update table whose original Excel spreadsheet 1 contains automatic links to  

Excel spreadsheet 2. 

 

 Update Function supports local area network (LAN) 

You can update table whose original Excel spreadsheet located in another computer of 

local area network (LAN). 

It's a fast method for collaborative working. 

You can create a template Excel table so that others in the office can import it into 

GstarCAD by using AutoXlsTable. 
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13.16.4. Calculate block quantity 

Calculate block quantity in different layers or current drawing, even based on its 

attribute, with the capability of real-time update. 

1)  On the AutoXlsTable menu, click Insert Function.Or click Insert Function button 

on the AutoXlsTable toolbar. 

 

2)    Select Block Calculate radio button. 

3)     Select block from the Block drop-down list. 

4)Select layer from the Layer drop-down list.*All* represents all layers of current 

drawing. 
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5)  Close the Insert Function dialog box. 

13.16.5. Calculate area/length 
 Define the selections of which you’d like to calculate the area/length. 

1)         On the CADAddonTools menu, point to AutoXlsTable, click User Define 

Selections.Or click User Define Selections button on the AutoXlsTable toolbar. 

 

2)         Click New Group button. 

3)         Select Area or Length radio button. 

4)         Type a name for your selections in the Name box. 

5)         Click New Group button. 

6)         Select objects. 

7)         Close the User Define Selections dialog box. 

 Insert Function 

1)         On the AutoXlsTable menu, click Insert Function.Or click Insert Function button 

on the AutoXlsTable toolbar. 
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2)         Select Area Calculate/Length Calculate radio button. 

3)         Select block from the Entity drop-down list. 

4)         Select layer from the Layer drop-down list. 

5)         Close the Insert Function dialog box. 
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